POJ 2155 Matrix

Matrix

Time Limit: 3000MS Memory Limit: 65536K

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

  1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
  2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.
Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

思路:

可以用树状数组实现,因为是矩阵所以一般就是二维树状数组了,然后打出模板,然后就是怎么去更新这个二维树状数组,首先就是把将x1 - n, y1- n的都更新一遍,这样就会造成比如一个4行4列的矩阵只要更新1 1到2 2中间的但是这个会把1 1到4 4的全部更新了,所以就要将3 1到2 2以及3 3到4 4以及1 3到2 4再进行翻转,因为是0 1翻转,所以可以用取模实现。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1010;
int book[maxn][maxn];
int n, m, t;
int lowbit(int x) {
    return x & (-x);
}
void Updata(int x, int y, int val) {
    for (int i = x; i <= n; i += lowbit(i)) {
        for (int j = y; j <= n; j += lowbit(j)) {
            book[i][j] += val;
        }
    }
}
int GetSum(int x, int y) {
    int sum = 0;
    for (int i = x; i >= 1; i -= lowbit(i)) {
        for (int j = y; j >= 1; j -= lowbit(j)) {
            sum += book[i][j];
        }
    }
    return sum;
}
int main() {
    scanf("%d", &t);
    while (t--) {
        scanf("%d %d", &n, &m);
        char s;
        memset(book, 0, sizeof(book));
        while (m--) {
            int x1, x2, y1, y2, x, y;
            getchar();
            scanf("%c", &s);
            if (s == 'C') {
                scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
                Updata(x1, y1, 1);
                Updata(x1, y2 + 1, 1);
                Updata(x2 + 1, y1, 1);
                Updata(x2 + 1, y2 + 1, 1);
            } else {
                scanf("%d %d", &x, &y);
                printf("%d\n", GetSum(x, y) % 2);
            }
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值