POJ 3668 Game of Lines

Game of Lines

Time Limit: 1000MS Memory Limit: 65536K

Description

Farmer John has challenged Bessie to the following game: FJ has a board with dots marked at N (2 ≤ N ≤ 200) distinct lattice points. Dot i has the integer coordinates Xi and Yi (-1,000 ≤ Xi ≤ 1,000; -1,000 ≤ Yi ≤ 1,000).

Bessie can score a point in the game by picking two of the dots and drawing a straight line between them; however, she is not allowed to draw a line if she has already drawn another line that is parallel to that line. Bessie would like to know her chances of winning, so she has asked you to help find the maximum score she can obtain.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i+1 describes lattice point i with two space-separated integers: Xi and Yi.

Output

  • Line 1: A single integer representing the maximal number of lines Bessie can draw, no two of which are parallel.

Sample Input

4
-1 1
-2 0
0 0
1 1

Sample Output

4

第一种方法:

思路:

水题,就是会用模板库就行了,每次都存进斜率,因为用的set所以最后直接输出size就行了。

#include <iostream>
#include <set>
#include <cstdio>
using namespace std;
const int inf = 0x7fffffff;
const int maxn = 210;
int main() {
    ios::sync_with_stdio;
    int n;
    set<double> st;
    double x[maxn], y[maxn];
    scanf("%d", &n);
    for (int i = 0; i < n; i++) scanf("%lf %lf", &x[i], &y[i]);
    for (int i = 0; i < n; i++) {
        for (int j = i + 1; j < n; j++) {
            double k;
            if (x[i] == x[j]) k = inf;
            else k = (y[i] - y[j]) / (x[i] - x[j]);
            st.insert(k);
        }
    }
    printf("%d", st.size());
    return 0;
}

第二种方法:

思路:

先将斜率排序,然后再进行比较。

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
using namespace std;
const int inf = 0x7fffffff;
const int maxn = 210;
int main() {
    ios::sync_with_stdio;
    int n;
    vector<double> v;
    double x[maxn], y[maxn];
    scanf("%d", &n);
    for (int i = 0; i < n; i++) scanf("%lf %lf", &x[i], &y[i]);
    for (int i = 0; i < n; i++) {
        for (int j = i + 1; j < n; j++) {
            double k;
            if (x[i] == x[j]) k = inf;
            else k = (y[i] - y[j]) / (x[i] - x[j]);
            v.push_back(k);
        }
    }
    int sum = 0;
    sort(v.begin(), v.end());
    for (int i = 1; i < v.size(); i++) {
        if (v[i] != v[i - 1]) sum++;
    }
    printf("%d", sum + 1);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值