题目
有 N 个盘子,每个盘子上写着一个仅由小写字母组成的英文单词。
你需要给这些盘子安排一个合适的顺序,使得相邻两个盘子中,前一个盘子上单词的末字母等于后一个盘子上单词的首字母。
请你编写一个程序,判断是否能达到这一要求。
输入格式
第一行包含整数 T,表示共有 T 组测试数据。
每组数据第一行包含整数 N,表示盘子数量。
接下来 N 行,每行包含一个小写字母字符串,表示一个盘子上的单词。
一个单词可能出现多次。
输出格式
如果存在合法解,则输出”Ordering is possible.”,否则输出”The door cannot be opened.”。
数据范围
1≤N≤105,
单词长度均不超过1000
输入样例:
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
输出样例:
The door cannot be opened.
Ordering is possible.
The door cannot be opened.
思路
- 题目和之前有一个单词环的题目思路是一样的,就是把每一个字符串的首字母和末字母作为点,然后进行建图,最后就是普通的判断欧拉回路问题了
代码
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 30;
int n;
int din[N], dout[N], p[N];
bool st[N];
int find(int x)
{
if (p[x] != x) p[x] = find(p[x]);
return p[x];
}
int main()
{
char str[1010];
int T;
scanf("%d", &T);
while (T -- )
{
scanf("%d", &n);
memset(din, 0, sizeof din);
memset(dout, 0, sizeof dout);
memset(st, 0, sizeof st);
for (int i = 0; i < 26; i ++ ) p[i] = i;
for (int i = 0; i < n; i ++ )
{
scanf("%s", str);
int len = strlen(str);
int a = str[0] - 'a', b = str[len - 1] - 'a';
st[a] = st[b] = true;//标记一下这个字母出现过
dout[a] ++, din[b] ++ ;
p[find(a)] = find(b);
}
int start = 0, end = 0;
bool success = true;
for (int i = 0; i < 26; i ++ )
if (din[i] != dout[i])//如果入度不等于出度,看一下是起始点还是结束点
{
if (din[i] == dout[i] + 1) end ++ ;
else if (din[i] + 1 == dout[i]) start ++ ;
else
{
success = false;
break;
}
}
if (success && !(!start && !end || start == 1 && end == 1)) success = false;//如果有多个起始点九尾false
int rep = -1;
for (int i = 0; i < 26; i ++ )
if (st[i])//看一下是否在同一个连通块内
{
if (rep == -1) rep = find(i);
else if (rep != find(i))
{
success = false;
break;
}
}
if (success) puts("Ordering is possible.");
else puts("The door cannot be opened.");
}
return 0;
}