1007 Maximum Subsequence Sum (25分)

题目

Given a sequence of K integers { N1 , N2 , …, NK​​ }. A continuous subsequence is defined to be { N​i
, N​i+1 , …, Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output

10 1 4

解题思路

经典的动态规划题。解题的难点在于要如何记录子序列首尾下标(indice)。若输入序列为全负,则输出0,但是还要考虑到输入序列为全0。因此,对于非全负的序列,要考虑到最大值为0的情况,所以初始的max应设为-1。

代码

#include <stdio.h>
#include <stdlib.h>
int main()
{
    int N;
    if(scanf("%d",&N)==1)
    {
        int *arr=(int *)malloc(sizeof(int)*N);
        for(int i=0;i<N;i++)
            scanf("%d",&arr[i]);
        int start=0,end=0;  //记录开始和结束位置
        int temp_s=start;   //记录过程中的开始点
        int sum=0;          //记录过程中的和
        int max=-1;			
        for(int i=0;i<N;i++)
        {
            if(sum<0)		//若为全负,则不会修改max的值,因此可以用max的大小来确定输出形式
            {				//不用特地记录是否为全负
                			//若max为0,则无法区分到底是全负还是全0
                sum=0;		
                temp_s=i;
            }
            sum=sum+arr[i];
            if(sum>max)
            {
                max=sum;
                start=temp_s;
                end=i;
            }
        }
        if(max<0)
            printf("0 %d %d",arr[0],arr[N-1]);		//一开始忘记输出首尾的值,测试点4出错
        else
            printf("%d %d %d",max,arr[start],arr[end]);
    }
    return 0;
}

结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值