【一只蒟蒻的刷题历程】 【PAT】 A1005 正确拼写

1005 Spell It Right (20分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five


题目大意:

1005正确拼写(20分)

给定一个非负整数N,您的任务是计算N的所有数字的总和,并以英语输出总和的每个数字。

输入规格:

每个输入文件包含一个测试用例。 每种情况占用一条线,其中包含N(≤10100)。

输出规格:

对于每个测试用例,请一行用英语单词输出总和的数字。 两个连续的单词之间必须有一个空格,但行尾不能有多余的空格。
样本输入:
12345

样本输出:

one five


代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <queue>
#include <set>
#include <map>
using namespace std;
int main() 
{
   char english[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
   string s;
   getline(cin,s);
   long long sum=0;
   for(int i=0;i<s.length();i++)
      sum+=s[i]-'0';
   vector<string> ans;
   if(sum==0) cout<<english[0];  //测试点2
   while(sum)
   {
   	   ans.push_back(english[sum%10]);
   	   sum/=10;
   }
   for(int i=ans.size()-1;i>=0;i--)
   {
   	   cout<<ans[i];
   	   if(i>=1)
   	   cout<<" ";
   }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值