【一只蒟蒻的刷题历程】 【PAT】 A1015 可逆素数

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No


题目大意:

任何数字系统中的可逆素数都是素数,该数字系统中的“反向”也是素数。 例如在十进制系统73中是可逆的素数,因为它的反面37也是素数。

现在给定任意两个正整数N(<10 5)和D(1 <D≤10),您应该确定N是否是具有基数D的可逆素数。
输入规格:

输入文件包含几个测试用例。 每个个案占据一行,该行包含两个整数N和D。输入以负N结束。
输出规格:

对于每个测试用例,如果N是带底数D的可逆素数,则在一行中打印“是”,否则打印“否”。
样本输入:

73 10
23 2
23 10
-2

样本输出:

Yes
Yes
No


思路:

理解能力太菜了,读不懂题目,而且我还是用翻译软件 翻译了题目的!!!我一直以为用转换后的进制数来判断是否为素数,原来是转换进制后再逆序,然后再转回十进制判断。。。。。。。。

d进制转换为十进制

for(int i=0;i<s.size();i++)  //d进制转十进制
    	shu = shu*d + s[i]-'0';

坑点0: 要判断1不是素数
坑点3: 判断素数时i * i <= x ,要写这个等号

代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <queue>
#include <set>
#include <map>
using namespace std;
int zhuan(int x,int d) 
 //转换d进制 放string里就已经倒置了,然后转回十进制
{
	string s;
	while(x)
	{
		s += x%d + '0';
		x/=d;
	}
	int shu=0;
    for(int i=0;i<s.size();i++)  //d进制转十进制
    	shu = shu*d + s[i]-'0';

	return shu;
}

bool isprime(int x) //判断素数
{
	if(x==1 || x==0) return 0; //测试点0
	for(int i=2;i*i<=x;i++)   //取等 测试点3
	 if(x%i==0) return 0;
	return 1;
} 

int main() 
{
   int n,d;
   while(cin>>n && n>=0)
   {
   	  cin>>d;
   	  	if(isprime(n) && isprime((zhuan(n,d)))) //都是素数
   	  	cout<<"Yes"<<endl;
   	  else  cout<<"No"<<endl;
   }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值