1054 The Dominant Color (二维数组出现次数最多的数)

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2^24). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:
For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

题意:
输入一个n * m数组,输出数组中出现次数大于n * m的一半且最多的数字。

思路:
1.用hash[i] = j 表示 i 出现了 j 次,每输入一个数,hash[num]++,最后输出hash[]中最大的下标就可以了,
缺点是如果输入的数字很大,如10000000,则遍历hash的时候复杂度较高。
2.直接输入矩阵,有且只有一个数出现的次数会大于一半的格子数 该数就是答案
3.定义一个map<int,int> mp,mp[30] = 7,表示30出现了7次,输入一个数字 num 后判断该数是否在mp中,如果在mp中,mp[num]++,否则令mp[num] = 1;

code2

#include <cstdio>
const int maxn = 0xfffffff;
int a[maxn] = {0};
int main()
{
    int n, m, num;
    scanf("%d%d", &n, &m);
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < m; j++)
        {
            scanf("%d", &num);
            a[num]++;
            if(a[num] > n * m / 2)      //解题技巧 有且只有一个数出现次数大于一半的格子数 该数就是答案
            {
                printf("%d", num);
                break;
            }
        }
    }
    return 0;
}

code3

#include <cstdio>
#include <map>
using namespace std;
int main()
{
    int n, m, num;
    scanf("%d%d", &n, &m);
    map<int,int> count;
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < m; j++)
        {
            scanf("%d", &num);
            if(count.find(num) != count.end())
                count[num]++;
            else
                count[num] = 1;
        }
    }
    int k = 0, MAX = 0;
    for(map<int,int>::iterator it = count.begin(); it != count.end(); it++)
    {
        if(it->second > MAX)
        {
            k = it->first;
            MAX = it->second;
        }
    }
    printf("%d", k);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
由于CWRU据集包含多个故障类型和多个工作状态,因此需要对据进行预处理和特征提取。以下是CWRU据集二维代码实现的一个简单示例: ``` import numpy as np import pandas as pd import matplotlib.pyplot as plt from scipy.fftpack import fft # Load data df = pd.read_csv('data.csv') # Preprocess data df = df.dropna() # Remove missing values df = df.loc[df['fault'] == 'inner_race'] # Select fault type df = df.loc[df['status'] == '7'] # Select working status df = df.drop(['fault', 'status'], axis=1) # Remove categorical columns # Feature extraction time_series = df.values # Convert to numpy array fft_series = np.abs(fft(time_series)) # Compute FFT fft_series = fft_series[:, :fft_series.shape[1]//2] # Keep only positive frequencies max_freqs = np.argmax(fft_series, axis=1) # Find dominant frequency for each sample features = np.column_stack((np.max(time_series, axis=1), max_freqs)) # Combine features # Visualize features plt.scatter(features[:, 0], features[:, 1]) plt.xlabel('Max amplitude') plt.ylabel('Dominant frequency') plt.show() ``` 在这个例子,我们首先加载CWRU据集的CSV文件,并进行一些预处理步骤。我们选择内圈故障类型和第7个工作状态,并删除分类列。接下来,我们进行特征提取,将每个样本的时域信号转换为频域信号,并提取最大振幅和主频率作为特征。最后,我们将特征可视化为二维空间的散点图。这个例子只是一个简单的示例,实际应用可能需要更复杂的特征提取和建模方法。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值