1015 Reversible Primes (素数+进制转换)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10^​5) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题意:
输入两个整数n和radix,如果n是素数且n在radix进制下反转后的数也是素数,则输出Yes,否则输出No
例如:
23的2进制是10111,10111的反转是11101,也就是10进制的29,也是素数,则输出Yes

思路:
用一个数组d,记录n的radix进制,反转后再换成10进制判断是不是素数即可。

while(n != 0)   //进制转换
            {
                d[len++] = n % radix;
                n /= radix;
            }

例如输入n = 8, radix = 2 则len = 4, d[0]~d[3]为0001, 刚好是8的二进制的逆序.

#include <cstdio>
#include <cmath>


bool isPrime(int n)     //判断素数
{
    if(n <= 1) return false;
    int sqr = (int)sqrt(1.0 * n);
    for(int i = 2; i <= sqr; i++)   
        if(n % i == 0)
            return false;
    return true;
}
int main()
{
    int n, radix;
    int d[111];     //存放radix进制数组
    while(scanf("%d", &n) != EOF)
    {
        if(n < 0)   break;      //如果n为负数,直接退出
        scanf("%d", &radix);
        if(isPrime(n) == false)     //n不是质数,直接输出No
            printf("No\n");
        else
        {
            int len = 0;    //记录radix进制数组的长度
            while(n != 0)   //进制转换
            {
                d[len++] = n % radix;
                n /= radix;
            }
            for(int i = 0; i < len; i++)    //按逆序转换进制
                n = n * radix + d[i];
            if(isPrime(n) == true)  //逆序是素数
                printf("Yes\n");
            else                    //逆序不是素数
                printf("No\n");
        }
    }
    return 0;
}

//如输入 8 2 则len = 4 d[0]~d[3] 0001 刚好是8的二进制的逆序

//for(int i = len - 1; i >= 0; i--)     //原样输出
//    n = n * radix + d[i];



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值