1018 Public Bike Management

13 篇文章 0 订阅

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:
PBMC -> S1-> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S​3, so that both stations will be in perfect conditions.

PBMC -> S2-> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax
​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci(i=1,⋯,N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: S​i, Sj, and Tijwhich describe the time T​ij taken to move betwen stations S​i and Sj. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S1−>⋯−>Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

题意:每个自行车站的最大容量为一个偶数Cmax,如果一个车站中单车的数量恰好为Cmax / 2,那么称处于完美状态。如果某个车站容量是满的或者空的,控制中心(处于结点0处)就会携带或者从路上收集一定数量的单车前往该车站,在路上会让所有的沿途车站都达到完美。现在给出Cmax,车站的数量n,问题车站sp,m条边,还有距离,求一条最短路径。输出需要从控制中心携带的自行车数目、最短路径、需要带回自行车的数目。
如果最短路径有多条,那么选择从控制中心携带单车数目最少的,如果还有多条,那么就选择从问题车站站带回的单车数最少的。

分析:求最短路径,直接可以用Dijkstra(求出多条最短路径), 输出需要从控制中心携带的自行车数目、最短路径、需要带回自行车的数目。加粗的部分也就是第二标尺和第三标尺,用DFS求第二标尺或第三标尺的最优值。
输入单车数量时直接将单车数量(点权)减去Cmax / 2,weight[i]点权为正,说明此车站有多余的车要带回控制中心,记为back,否则说明此车站需要补给,补给量为abs(weight[i]),记为need。

int id = tempPath[i];
if(weight[id] > 0)		//需要带回
{
    back += weight[id];	//以前要带回的加上当前要带回的	
}
else					//需要补给
{
    if(back > abs(weight[id]))	
    {
        back -= abs(weight[id]);	//减去补给量
    }
    else		//当前持有量不够不急
    {
        need +=  abs(weight[id]) - back;	//不够的部分从PBMC携带
        back = 0;	//当前的自行车全部用来补给
    }
}
#include<bits/stdc++.h>
using namespace std;
const int maxn = 510;
const int INF = 100000;
int Cmax, n, sp, m, G[maxn][maxn], weight[maxn];
int d[maxn];
int minNeed = INF, minBack = INF;     //minNeed记录最少携带的数目,minBack记录最少带回的数目
bool vis[maxn] = {false};

vector<int> pre[maxn];
vector<int> tempPath, path;

void dijkstra(int s)
{
    fill(d, d + maxn, INF);
    d[s] = 0;
    for(int i = 0; i <= n; i++)     //加上控制中心一共是n+1个点
    {
        int u = -1, MIN = INF;
        for(int j = 0; j <= n; j++)
        {
            if(vis[j] == false && d[j] < MIN)
            {
                u = j;
                MIN = d[j];
            }
        }
        if(u == -1) return;
        vis[u] = true;
        for(int v= 0; v <= n; v++)
        {
            if(vis[v] == false && G[u][v] != INF)
            {
                if(G[u][v] + d[u] < d[v])
                {
                    d[v] = G[u][v] + d[u];
                    pre[v].clear();
                    pre[v].push_back(u);
                }
                else if(G[u][v] + d[u] == d[v])
                {
                    pre[v].push_back(u);
                }
            }
        }
    }
}


void dfs(int v)
{
    if(v == 0)
    {
        tempPath.push_back(v);
        int need = 0, back = 0;
        for(int i = tempPath.size() - 1; i >= 0; i--)
        {
            int id = tempPath[i];
            if(weight[id] > 0)
            {
                back += weight[id];
            }
            else
            {
                if(back > abs(weight[id]))
                {
                    back -= abs(weight[id]);
                }
                else
                {
                    need +=  abs(weight[id]) - back;
                    back = 0;
                }
            }
        }
        if(need < minNeed)      //需要从PBMC携带的单车数量更少(第二标尺)
        {
            minNeed = need;
            minBack = back;
            path = tempPath;
        }
        else if(need == minNeed && back < minBack)  //需要从PBMC携带的单车数量相同,但是带回PBMC的数量更少(第三标尺)
        {
            minBack = back;
            path = tempPath;
        }
        tempPath.pop_back();
        return;
    }
    tempPath.push_back(v);
    for(int i = 0; i < pre[v].size(); i++)
        dfs(pre[v][i]);
    tempPath.pop_back();
}
int main()
{
    scanf("%d%d%d%d", &Cmax, &n, &sp, &m);
    for(int i = 1; i <= n; i++)
    {
        scanf("%d", &weight[i]);
        weight[i] -= Cmax / 2;
    }
    int u, v;
    fill(G[0], G[0] + maxn * maxn, INF);
    for(int i = 1; i <= m; i++)
    {
        scanf("%d%d", &u, &v);
        scanf("%d", &G[u][v]);
        G[v][u] = G[u][v];
    }
    dijkstra(0);
    dfs(sp);
    printf("%d ", minNeed);
    for(int i = path.size() - 1; i >= 0; i--)
    {
        printf("%d", path[i]);
        if(i > 0)   printf("->");
    }
    printf(" %d", minBack);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值