PAT 1001 A+B Format C++实现 解题思路分析

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991


    解题思路:将sum转化为字符串,每三位之后且有第四位就添加一个逗号
        负数打印出‘-’,将负数转换成正数。
    比如:1000存入数组成为000,1
           -999991 存入数组成为199,999
        然后倒序输出

 

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<vector>

using namespace std;
int main()
{
    int a = 0,b = 0;
    cin >> a;cin >>b;
    int sum  = a + b;
    int cou = 0;
    if(0 == sum)
    {
       cout << 0 <<endl;
        return 0;
    }
    if(sum < 0)
    {
        cout << "-";
        sum = -sum ;
    }
    vector<char> arr;//定义数组存sum
    int flag = 0;
    for(int i = 0 ; i < 10 ; i++)
    {
        flag++;
        arr.push_back(sum %10 +'0');    //转化成字符存入数组中

        sum /= 10;
        if(0 == sum)
            break;
        if(0 == flag%3)
            arr.push_back(',');
    }
    for(int i = arr.size()-1 ; i>=0 ; i--)
        cout << arr[i] ;
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值