2020.8 复习 7-13 复数类的运算 //PTA

本文介绍了一个使用C++实现复数运算的类设计案例。通过定义Complex类,实现了复数的加法、减法等基本运算,并提供了显示复数的方法。文章详细展示了如何重载运算符以实现复数的加减操作,以及如何在主函数中输入复数并进行运算。
摘要由CSDN通过智能技术生成

题意

根据以下代码段完善 ?? 处内容及程序内容,以实现规定的输出。

class Complex
{
	public:
		Complex(double r=0, double i=0):real(r), imag(i){	}
		Complex operator+( ?? ) const;//重载双目运算符'+'
		Complex operator-=( ?? ); //重载双目运算符'-='
		friend Complex operator-( ?? );//重载双目运算符'-'
		void Display() const;
	private:
		double real;
		double imag;
};

void Complex::Display() const
{
	cout << "(" << real << ", " << imag << ")" << endl;
}

int main()
{
	double r, m;
	cin >> r >> m;
	Complex c1(r, m);
	cin >> r >> m;
	Complex c2(r, m);
	Complex c3 = c1+c2;
	c3.Display();
	c3 = c1-c2;
	c3.Display();
	c3 -= c1;
	c3.Display();
	return 0;
}

输入格式:

输入有两行,分别为两个复数的实部与虚部。

输出格式:

按样例格式输出结果。

输入样例:

在这里给出一组输入。例如:

4 2
3 -5

输出样例:

在这里给出相应的输出。例如:

(7, -3)
(1, 7)
(-3, 5)

#include <bits/stdc++.h>
using namespace std;
class Complex
{
public:
    Complex(double r = 0, double i = 0) : real(r), imag(i) {}
    Complex operator+(Complex a) const;             //重载双目运算符'+'
    Complex operator-=(Complex a);                  //重载双目运算符'-='
    friend Complex operator-(Complex a, Complex b); //重载双目运算符'-'
    void Display() const;

private:
    double real;
    double imag;
};

void Complex::Display() const
{
    cout << "(" << real << ", " << imag << ")" << endl;
}
Complex Complex::operator+(Complex a) const
{
    return Complex(real + a.real, imag + a.imag);
}
Complex Complex::operator-=(Complex a)
{
    
    real -= a.real;
    imag -= a.imag;
    return Complex(real,imag);
}
Complex operator-(Complex a, Complex b)
{
    return Complex(a.real - b.real, a.imag - b.imag);
}
int main()
{
    double r, m;
    cin >> r >> m;
    Complex c1(r, m);
    cin >> r >> m;
    Complex c2(r, m);
    Complex c3 = c1 + c2;
    c3.Display();
    c3 = c1 - c2;
    c3.Display();
    c3 -= c1;
    c3.Display();
    return 0;
}
import java.io.*; public class Book{ double sb; double xb; Book(double x,double y){ this.sb=x; this.xb=y; } Book(){ } public static void main(String args[]){ System.out.println("请输入数据:"); double a=0; double b=0; double c=0; double d=0; String s; BufferedReader in = new BufferedReader(new InputStreamReader(System.in)); System.out.println("请输入第一个复数的实部:"); try{ s = in.readLine(); a=Double.parseDouble(s); } catch(IOException e) { System.out.println("抛掷异常");} System.out.println("请输入第一个复述的虚部:"); try{ s = in.readLine(); b =Double.parseDouble(s); } catch(IOException e) { System.out.println("抛掷异常");} System.out.println("请输入第二个复述的实部:"); try{ s = in.readLine(); c =Double.parseDouble(s); } catch(IOException e) { System.out.println("抛掷异常");} System.out.println("请输入第二个复述的虚部:"); try{ s = in.readLine(); d =Double.parseDouble(s); } catch(IOException e) { System.out.println("抛掷异常");} Book h; h=new Book(a,b); Book j; j=new Book(c,d); System.out.println("您输入的一个数为:"); toString(h); System.out.println("您输入的二个数为:"); toString(j); Book k; k=new Book(); char z='y'; do{ System.out.println("请选择您要进行的计算:"); System.out.println("1 :进行加法运算"); System.out.println("2 :进行减法运算"); System.out.println("3 :进行修改"); System.out.println("4 :进行乘法运算"); System.out.println("5 :进行除法运算"); System.out.println("6 :查看修改结果"); int i=0; try{ i= Integer.parseInt(in.readLine()); } catch(IOException e) { System.out.println("抛掷异常");} switch(i) { case 1: k.sb=jia(h.sb,j.sb); k.xb=jia(h.xb,j.xb); System.out.println("计算结果的实部为:"+k.sb); System.out.println("计算结果的虚部为:"+k.xb); toString(k); break ; case 2: k.sb=jian(h.sb,j.sb); k.xb=jian(h.xb,j.xb); System.out.println("计算结果的实部为:"+k.sb); System.out.println("计算结果的虚部为:"+k.xb); toString(k); brea
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值