HDU 2752 Seek the Name, Seek the Fame(next数组的理解)

HDU 2752 Seek the Name, Seek the Fame

013
传送门:http://poj.org/problem?id=2752

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input
ababcababababcabab
aaaaa

Sample Output
2 4 9 18
1 2 3 4 5

题意: 给出一个字符串str,求出str中存在多少子串,使得这些子串既是str的前缀,又是str的后缀。从小到大依次输出这些子串的长度。

思路:这个时候就要对next数组的理解很深刻了呀,这里给出借鉴来大佬们的见解next数组的含义:
next[i]表示前面长度为i的子串中,前缀和后缀相等的最大长度。

然后我们利用伪递归的形式写,求出len处的next值,并递归的向下求出所有的next值,得到的就是答案。

AC代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <string>
#include <math.h>

using namespace std;
typedef long long ll;

const int maxn = 400000+10;
char p[maxn]; //p是子串, t是模板串
int nex[maxn];

void getnex()
{
    int len = strlen(p);
    nex[0] = -1;
    int j = 0, k= -1;

    while(j < len)
    {
        if(k== -1 || p[k] == p[j])
            nex[++j] = ++k;
        else
            k=nex[k];
    }
}

int main()
{
    while(~scanf("%s", p))
    {
        int len = strlen(p);

        getnex();
        int s[maxn];
        int k = 0;

        s[k++] = len;
        for(int i = len; i > 0; )
        {
            s[k++] = nex[i];
            i = nex[i];
        }

        for(int i = k-2; i >= 0; i--)
        {
            if(i == k-2)
                printf("%d", s[i]);
            else
                printf(" %d", s[i]);
        }
        puts("");
    }
    return 0;
}

next数组好啊 多加思考

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值