求前缀表达式的值

3-8 求前缀表达式的值 (20分)

算术表达式有前缀表示法、中缀表示法和后缀表示法等形式。前缀表达式指二元运算符位于两个运算数之前,例如2+3*(7-4)+8/4的前缀表达式是:+ + 2 * 3 - 7 4 / 8 4。请设计程序计算前缀表达式的结果值。

输入格式:

输入在一行内给出不超过30个字符的前缀表达式,只包含+、-、*、/以及运算数,不同对象(运算数、运算符号)之间以空格分隔。

输出格式:

输出前缀表达式的运算结果,保留小数点后1位,或错误信息ERROR。

输入样例:
    • 2 * 3 - 7 4 / 8 4
输出样例:

13.0

类似的题

3-7 表达式转换 (20分)

代码
#include <iostream>
#include <algorithm>
#include <string>
#include <stack>
using namespace std;
bool num(char c){
    if(c>='0'&&c<='9') return true;
    else return false;
}
int main(){
    ios::sync_with_stdio(false);
    cin.tie(0),cout.tie(0);
    string s;
    int flag=1;
    stack<string> part;
    stack<double> num;
    getline(cin,s);
    for(int i=0;i<s.length();i++){
    	string ss;
        while(s[i]!=' '&&i<s.length()){
            ss+=s[i];
            i++;
        }
        part.push(ss);
    }
    while(!part.empty()){
    	if(part.top()=="+"||part.top()=="-"||part.top()=="*"||part.top()=="/"){
    		if(num.size()>=2){
    			double a=num.top();
    			num.pop();
    			double b=num.top();
    			num.pop();
    			if(part.top()=="/"&&b==0){
    				printf("ERROR");
    				flag=0;
    				break;
				}else{
					if(part.top()=="+"){
						num.push(a+b);
					}else if(part.top()=="-"){
						num.push(a-b);
					}else if(part.top()=="*"){
						num.push(a*b);
					}else if(part.top()=="/"){
						num.push(a/b);
					}
				}
			}else{
				printf("ERROR");
    			flag=0;	
    			break;
			}
            part.pop();
		}else{
			num.push(stof(part.top()));
			part.pop();
		}
	}
	if(flag) printf("%.1f",num.top());
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值