PTA | 03-树2 List Leaves (25分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Solution: 题目的意思很明显给定一个树输出它的叶子节点(从上到下,从左到右输出)。其中给定的这棵树有N个节点(从0开始编号),对于每一个节点还给出它的左右儿子的索引及左右儿子的位置。因此,我们可以采用顺序存储结构来存储这颗二叉树,因为树是以顺序索引的格式给定的,因此我们需要确定这个二叉树的根节点,其中根节点最明显的特征就是他不是任何节点的儿子,因此我们需要采用一个标记数组来确定其根节点。其中输出叶子节点可以采用层次遍历的方法进行输出。其中我们使用 null=−1null=−1来表示该节点不存在。

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

Code

#include<bits/stdc++.h>
using namespace std;
typedef int Tree;
#define Null -1
struct TreeNode {
	int data;
	Tree left;
	Tree right;
};

int buildTree(vector<TreeNode>&tree,int N) {
	Tree Root = -1;
	char cl, cr;
	vector<int>book(N, 0);

	for (int i = 0; i < N; ++i) {
		cin >> cl >> cr;
		tree[i].data = i;
		if (cl != '-') {
			tree[i].left = (int)cl - '0';
			book[tree[i].left] = 1;
		}
		else
			tree[i].left = Null;
		if (cr != '-') {
			tree[i].right = (int)cr - '0';
			book[tree[i].right] = 1;
		}
		else
			tree[i].right = Null;
	}
	int i = 0;
	for (; i < N; ++i)
		if (!book[i]) {
			Root = i;
			break;
		}
	return Root;
}

vector<int> findLeaves(const vector<TreeNode>&tree, Tree Root) {
	vector<int> leaves;
	queue<TreeNode> qu;
	TreeNode node;

	if (Root == Null)return {};
	qu.push(tree[Root]);
	while (!qu.empty()) {
		node = qu.front();
		qu.pop();
		//如果该节点左右儿子都不存在则为根节点
		if ((node.left == Null) && node.right == Null)
			leaves.push_back(node.data);
		if (node.left != Null) qu.push(tree[node.left]);
		if (node.right != Null) qu.push(tree[node.right]);
	}
	return leaves;
}

int main() {
	int N;

	Tree Root;
	cin >> N;
	vector<TreeNode>tree(10);
	Root = buildTree(tree, N);

	auto res = findLeaves(tree, Root);
	for (decltype(res.size())i = 0; i != res.size(); ++i)
	{
		cout << res[i];
		//注意:最后一个数字输出后没有空格
		i != res.size() - 1 ? cout << " " : cout << endl;
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述: 给定一棵二叉排序和一个值,求该值在中出现的次数。 输入格式: 第一行包含整数 n,表示中节点个数。 接下来 n 行,每行包含一个整数,表示当前节点的值。 最后一行包含一个整数x,表示需要统计出现次数的值。 输出格式: 共一行,包含一个整数,表示该值在中出现的次数。 输入样例: ``` 5 2 1 2 3 4 2 ``` 输出样例: ``` 2 ``` 算法1: 递归遍历,统计值出现的次数。 时间复杂度 平均时间复杂度为O(logn),最坏时间复杂度为O(n)。 参考文献 Python 代码 ```python class TreeNode(object): def __init__(self, x): self.val = x self.left = None self.right = None class Solution(object): def searchBST(self, root, val): """ :type root: TreeNode :type val: int :rtype: bool """ if not root: return 0 if val == root.val: return 1 + self.searchBST(root.left, val) + self.searchBST(root.right, val) elif val < root.val: return self.searchBST(root.left, val) else: return self.searchBST(root.right, val) ``` 算法2: 迭代遍历,统计值出现的次数。 时间复杂度 平均时间复杂度为O(logn),最坏时间复杂度为O(n)。 参考文献 Python 代码 ```python class TreeNode(object): def __init__(self, x): self.val = x self.left = None self.right = None class Solution(object): def searchBST(self, root, val): """ :type root: TreeNode :type val: int :rtype: bool """ if not root: return 0 count = 0 stack = [root] while stack: node = stack.pop() if node.val == val: count += 1 if node.left and node.val >= val: stack.append(node.left) if node.right and node.val <= val: stack.append(node.right) return count ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值