题目描述:原题链接
Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
(农夫 John 建造了一座很长的畜栏,它包括N (2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,…,xN (0 <= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢)
Input
- Line 1: Two space-separated integers: N and C * Lines 2…N+1: Line i+1 contains an integer stall location, xi
(第一行:空格分隔的两个整数N和C
第二行—第N+1行:i+1行指出了xi的位置)
Output
- Line 1: One integer: the largest minimum distance
(第一行:一个整数,最大的最小值)
Sample Input
5 3
1
2
8
4
9
Sample Output
3
把牛放在1,4,8这样最小距离是3
思路:
先将编号从小到大排列,利用二分查找可能的间隔,对于可能的间隔进行贪心使间隔尽可能大,如果可以使所有牛都装下,即为答案。
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[100005];
int N,C;
bool check(int b){
int head=a[0];
int cnt=1;
for(int i=0;i<N;i++)
{
if(a[i]-head>=b)
{
head=a[i];
cnt++;
if(cnt>=C)
return true;
}
}
return false;
}
int main()
{
cin>>N>>C;
for(int i=0;i<N;i++)cin>>a[i];
sort(a,a+N);
int mid;
int l=0;
int r=a[N-1]-a[0];
while(l<=r)
{
mid=(l+r)/2;
if(check(mid))
l=mid+1;
else
r=mid-1;
}
cout<<r<<endl;
return 0;
}