Uva514-Rails【 栈 + 模拟】通俗易懂的题解

1.题目

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station
was built in last century. Unfortunately, funds were extremely limited that time. It was possible to
establish only a surface track. Moreover, it turned out that the station could be only a dead-end one
(see picture) and due to lack of available space it could have only one track.
The local tradition is that every train arriving from the direction A continues in the direction
B with coaches reorganized in some way. Assume that the train arriving from the direction A has
N ≤ 1000 coaches numbered in increasing order 1, 2, . . . , N. The chief for train reorganizations must
know whether it is possible to marshal coaches continuing in the direction B so that their order will
be a1.a2, . . . , aN . Help him and write a program that decides whether it is possible to get the required
order of coaches. You can assume that single coaches can be disconnected from the train before they
enter the station and that they can move themselves until they are on the track in the direction B. You
can also suppose that at any time there can be located as many coaches as necessary in the station.
But once a coach has entered the station it cannot return to the track in the direction A and also once
it has left the station in the direction B it cannot return back to the station.
Input
The input file consists of blocks of lines. Each block except the last describes one train and possibly
more requirements for its reorganization. In the first line of the block there is the integer N described
above. In each of the next lines of the block there is a permutation of 1, 2, . . . , N. The last line of the
block contains just ‘0’.
The last block consists of just one line containing ‘0’.
Output
The output file contains the lines corresponding to the lines with permutations in the input file. A line
of the output file contains ‘Yes’ if it is possible to marshal the coaches in the order required on the
corresponding line of the input file. Otherwise it contains ‘No’. In addition, there is one empty line after
the lines corresponding to one block of the input file. There is no line in the output file corresponding
to the last “null” block of the input file.
Sample Input
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
Sample Output
Yes
No

Yes

2.思路

车站C相当于一个栈。我们用模拟法来做,假设我们已经处理了前i - 1节从B方向驶出的车厢,我们现在要让a驶出。若ai不在车站C中,我们就让若干车厢从A方向驶入车站C,直到ai驶人,再将它从B方向驶出;若ai在车站C中,如果它是车站C中停在最前面的,则将它从B方向驶出,否则原问题无解。

如样例中,出栈序列是3 5 4 2 1,模拟过程如下:

①一开始栈为空;

②由于3不在栈中,就需要把1,2,3依次进栈,再出栈,这样符合出栈序列第一个数是3,当前栈为{1,2};

③第2个出栈的是5,5不在栈中,就要把4,5压栈,再出栈就可以得到5,此时栈为{1 2,4};

④第3个出栈的是4,正好是栈顶元素,直接出栈,栈变为{1,2};

⑤第4个出栈的是2,正好是栈顶元素,直接出栈,栈变为{2};

⑥第5个出栈的是1,正好是栈顶元素,直接出栈,栈变为{ }。

在模拟过程中没有碰到要出栈的数在栈中但不是栈顶元素的情况,所以该方案可行。
注意这道题的输入输出格式。

3.AC代码

#include<iostream>
#include<cstdio>
#include<algorithm>
const int maxn = 1e3 + 10;
using namespace std;
int st[maxn],a[maxn],top;
int main()
{
	int n;
	while (cin >> n && n)
	{
		while (1) 
		{
			cin >> a[1];
			if (a[1]==0)
			{
				break;
			}
			else
			{
				for (int i = 2; i <= n; i++)
				{
					cin >> a[i];
				}
			}
			top = 0;
			int cur = 1,flag=1;//cur是当前要从A方向驶入的车厢号
			for (int i = 1; i <= n; i++)
			{
				while (cur <= a[i])
				{
					st[++top] = cur++;
				}
				if (st[top] != a[i])
				{
					flag = 0;
					break;
				}
				else
				{
					top--;
				}

			}
			if (flag)
			{
				cout << "Yes" << endl;
			}
			else
			{
				cout << "No" << endl;
			}
		}
		cout << endl;
	}
	return 0;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林小鹿@

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值