鸽巢原理 poj2356

题目描述

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).
Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.
Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

输入样例

5
1
2
3
4
1

输出样例

2
2
3

题目意思:大体意思就是从一堆数中选出几个数满足这几个数的和是给定 n 的倍数, 输出一个满足的答案即可

这就很nice

#include <iostream>

#include <cstdio>

using namespace std;

const int N = 10010;

int a[N], sum[N], t, s;

int vis[N];

int main()
{
    int n; cin >> n;
    
    bool flag = false;
    
    for(int i = 1; i <= n ; i ++)
    {
        scanf("%d", a + i);
        
        if(!flag) sum[i] = (sum[i - 1] + a[i]) % n;
        
        if((vis[sum[i]] != 0 || sum[i] == 0) && !t) 
        {
            t = i, s = vis[sum[i]], flag = true;
        }
        
        if(!flag)vis[sum[i]] = i;
    }
    if(vis[0] != 0) 
    {
        printf("%d\n", vis[0]);
        for(int i = 1; i <= vis[0] ; i ++)
        {
            printf("%d\n", a[i]);
        }
    }
    else 
    {
        printf("%d\n", t - s);
        for(int i = s + 1; i <= t; i ++)
        {
            printf("%d\n",a[i]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值