C - Audiophobia UVA - 10048

1.题目
C - Audiophobia UVA - 10048
Consider yourself lucky! Consider yourself lucky to be still breathing and having fun participating in
this contest. But we apprehend that many of your descendants may not have this luxury. For, as you
know, we are the dwellers of one of the most polluted cities on earth. Pollution is everywhere, both in
the environment and in society and our lack of consciousness is simply aggravating the situation.
However, for the time being, we will consider only one type of pollution - the sound pollution. The
loudness or intensity level of sound is usually measured in decibels and sound having intensity level 130
decibels or higher is considered painful. The intensity level of normal conversation is 6065 decibels and
that of heavy traffic is 7080 decibels.
Consider the following city map where the edges refer to streets and the nodes refer to crossings.
The integer on each edge is the average intensity level of sound (in decibels) in the corresponding street.
To get from crossing A to crossing G you may follow the following path: A-C-F-G. In that case
you must be capable of tolerating sound intensity as high as 140 decibels. For the paths A-B-E-G,
A-B-D-G and A-C-F-D-G you must tolerate respectively 90, 120 and 80 decibels of sound intensity.
There are other paths, too. However, it is clear that A-C-F-D-G is the most comfortable path since
it does not demand you to tolerate more than 80 decibels.
In this problem, given a city map you are required to determine the minimum sound intensity level
you must be able to tolerate in order to get from a given crossing to another.
Input
The input may contain multiple test cases.
The first line of each test case contains three integers C(≤ 100), S(≤ 1000) and Q(≤ 10000) where
C indicates the number of crossings (crossings are numbered using distinct integers ranging from 1 to
C), S represents the number of streets and Q is the number of queries.
Each of the next S lines contains three integers: c1, c2 and d indicating that the average sound
intensity level on the street connecting the crossings c1 and c2 (c1 ̸= c2) is d decibels.
Each of the next Q lines contains two integers c1 and c2 (c1 ̸= c2) asking for the minimum sound
intensity level you must be able to tolerate in order to get from crossing c1 to crossing c2.
The input will terminate with three zeros form C, S and Q.
Output
For each test case in the input first output the test case number (starting from 1) as shown in the
sample output. Then for each query in the input print a line giving the minimum sound intensity level
(in decibels) you must be able to tolerate in order to get from the first to the second crossing in the
query. If there exists no path between them just print the line “no path”.
Print a blank line between two consecutive test cases.
Sample Input
7 9 3
1 2 50
1 3 60
2 4 120
2 5 90
3 6 50
4 6 80
4 7 70
5 7 40
6 7 140
1 7
2 6
6 2
7 6 3
1 2 50
1 3 60
2 4 120
3 6 50
4 6 80
5 7 40
7 5
1 7
2 4
0 0 0
Sample Output
Case #1
80
60
60
Case #2
40
no path
80

2.题目大意
从A地到B地,每个街道上有大小不同的噪音,求出从A到B经过的所有街道的中噪音的最大值。也就是求两点之间的路径上的最大边权最小,输出这个边权。

3.解题思路
其实就是floyd的一种变形,每次可以得到i->j的噪音max2,和i->k的噪音,k->j的噪音中的最大值max1,然后我们需要的是max1和max2两个数的最小值,就是: graph[i][j] = min(graph[i][j] , max(graph[i][k],graph[k][j]));
其中i为起点,k为中间点,j为终点。然后输出似乎不记得是不是要注意下。

4.floyd的一种变形
https://blog.csdn.net/weixin_45674799/article/details/104410012
上面这道题中有讲到基础的floyd算法,这题就是运算式那里需要变形一下。

5.AC代码

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
#define maxn 110
#define inf 0x3f3f3f3f
int graph[maxn][maxn], visit[maxn];
int C,S,Q;
void flyod()
{
    for(int k = 0; k<=C; k++)
    {
        for(int i = 0; i<=C; i++)
        {
            for(int j = 0; j<=C; j++)
            {
                graph[i][j] = min(graph[i][j] , max(graph[i][k],graph[k][j]));
            }
        }
    }
}
int main()
{
    int casenum = 1;
   while(scanf("%d%d%d",&C,&S,&Q) == 3 &&!(!C&&!Q&&!S))
   {
  //     if(casenum!= 1) printf("\n");
       int a,b,cost;
       memset(graph,inf,sizeof(graph));
       for(int i = 0; i <=C; i++) graph[i][i] = 0;
       for(int i = 0; i<S ; i++)
       {
           scanf("%d%d%d",&a,&b,&cost);
           graph[a][b] = graph[b][a] = cost;
       }
       flyod();
       printf("Case #%d\n",casenum++);
       for(int i = 0; i<Q; i++)
       {
           scanf("%d%d",&a,&b);
           if(graph[a][b] == inf) printf("no path\n");
           else printf("%d\n",graph[a][b]);
       }
     //  printf("\n");
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值