Syins写的dfs-写条件《自我感觉还挺新颖的(其实是我比较菜)》-Anagrams by Stack

Anagrams by Stack

Time Limit: 2000 ms

Memory Limit: 65536 KB

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]
where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]
and the sequences should be printed in “dictionary order”. Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.
Process
A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it’s too short), neither is
i i o o o i (there’s an illegal pop of an empty stack)
Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output

[
i i i i o o o i o o
i i i i o o o o i o
i i o i o i o i o o
i i o i o i o o i o
]
[
i o i i i o o i i o o o
i o i i i o o o i o i o
i o i o i o i i i o o o
i o i o i o i o i o i o
]
[
]
[
i i o i o i o o
]
乍一看,栈?
然后,不对,还要dfs。
这道题目的条件还是困扰了我一段时间,虽然反复告诉自己dfs嘛,很简单啦 就是一次调用解决一步要做的事,但我还是一下子没反应过来(说起来还是菜啊/(ㄒoㄒ)/~~)
像我这样的,脑子一热,直接就上手,就来了一个对每一个字符dfs,然后写了半天懵的一匹;
期间也看过别人的代码,但第一反应就是,这。。什么东西,看了两眼,感觉极其难受,不知道是为什么,(说这么多呢,其实是他们代码一写好几段,懒的看)于是放弃😭;
还好关键时刻冷静了一波,下面是思路

👇:

前面也说了dfs就是在每一次调用时解决好当前要做的事情
那么问题来了,这道题目的步骤是多少?
是字符串的长度吗?
每一个字符都是两种状态(i或o)所以按字符串的长度来?(这里要是没考虑好,回读的问题会带来很大麻烦,不一定写不出来,不过一定很麻烦,我一开始就是这么考虑,快写🤮了)
再转一下思路就会发现,如果可以转出那么必定输出2字符串的长度;
欸,这么一想,大有可为,直接按2
字符串的长度来,当前步骤执行的无非是i或o,而且真的没有其他可能;
于是accepted;

代码:

#include<iostream>
#include<stack>
#include<string.h>
using namespace std;
char a[100],b[100],c[100];
stack<char>y;
void dfs(int n,int m);
int main()
{
    while(cin>>a){
        cin>>c;
        while(!y.empty())
            y.pop();
        cout<<'['<<endl;
        if(strlen(a)==strlen(c))dfs(0,0);
        cout<<']'<<endl;
    }
    return 0;
}
void dfs(int n,int m){
    int i;
    if(n>strlen(a)||m>strlen(a))return;
    if(n==strlen(a)&&m==strlen(a)){
        for(i=0;i<n+m;i++)
            cout<<b[i]<<' ';
        cout<<endl;
        return;
    }
    if(n<strlen(a)){
        y.push(a[n]);
        b[n+m]='i';
        dfs(n+1,m);
        y.pop();
    }
    if(m<strlen(a)&&!y.empty()&&y.top()==c[m]){
        char x=y.top();
        y.pop();
        b[n+m]='o';
        dfs(n,m+1);
        y.push(x);
    }
    dfs(n+1,m);
}

这里考虑到输入有字符串的长度次,而且输出有字符串的长度次,所以用n,m两个参数,用n+m来表示当前步骤数;

1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值