SDNU_ACM_ICPC_2020_Winter_Practice_4th H 斐波那契

题目

Mr. Frog has n sticks, whose lengths are 1,2, 3⋯n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.
Input
The first line contains only one integer T (T≤20), which indicates the number of test cases.

For each test case, there is only one line describing the given integer n (1≤n≤20).
Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.
Sample Input
3
4
5
6
Sample Output
Case #1: 1
Case #2: 1
Case #3: 2

大意: 输入样例数T,每一行输入n,代表有n根木棍,长度依次为1~n
问至少拿走几根木棍,使得剩下的木棍任意三根都不能拼成一个三角形。

思路

一个三角形,任意两边之和大于第三边

而斐波那契数列的一个性质就是,其中的每一个数都可以找到两个斐波那契数,使这两个数的和与它相等。

所以,只要拿走长度不是斐波那契数的木棍即可

小于20 的斐波那契数有
1 2 3 5 8 13

代码

#include <iostream>
#include <string>
#include <cmath>
#include <cstring>
using namespace std;
int main()
{
    int n,a[21]={0,0,0,0,1,1,2,3,3,4,5,6,7,7,8,9,10,11,12,13,14};
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        int f;
        cin>>f;
        cout<<"Case #"<<i<<": "<<a[f]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值