POJ 2777 线段树 染色问题

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, … L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

  1. “C A B C” Color the board from segment A to segment B with color C.
  2. “P A B” Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, … color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains “C A B C” or “P A B” (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

题意:

一条很长(L)的画板,有T种颜色,O个操作;每次操作将一个区间刷成一种颜色,或者查询一个区间内所含的颜色数。一开始,黑板被漆成了1色。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
#define lson l,m,rt<<1    ///乘2
#define rson m+1,r,rt<<1|1   ///乘2加1
const int N=1e5+10;
int sum[N*4],lazy[N*4];
int a[N];
void pu(int rt)
{
    sum[rt]=sum[rt<<1]|sum[rt<<1|1];
}
void pd(int rt)
{
    if(lazy[rt])
    {
        sum[rt<<1]=sum[rt<<1|1]=lazy[rt];
        lazy[rt<<1]=lazy[rt<<1|1]=lazy[rt];
        lazy[rt]=0;
    }
}
void build(int l,int r,int rt)
{
    sum[rt]=lazy[rt]=0;
    if(l==r)
    {
        sum[rt]=1;
        return ;
    }
    int m=(l+r)>>1;
    build(lson);build(rson);
    pu(rt);///注释掉下一句
    ///sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void update(int l,int r,int rt,int ql,int qr,int x)
{
    if(ql>r||qr<l)return ;
    if(ql<=l&&r<=qr)///全包含
    {
        lazy[rt]=1<<(x-1);///此区间正确,但下一区间要改
        sum[rt] =1<<(x-1);
        ///更新区间和
        return;
    }
    pd(rt);
    int m=(l+r)>>1;
    if(ql<=m)update(lson,ql,qr,x);
    if(qr>m)update(rson,ql,qr,x);
    pu(rt);
}

int query(int l, int r, int rt, int ql, int qr)
{
    if(ql>r||qr<l)return 0;
	if (ql <= l && r <= qr) {
		return sum[rt];
	}///全包含
	int m = (l + r) >> 1;
	pd(rt);
	return query(rson, ql, qr)|query(lson, ql, qr);
}

int main() {
	ios::sync_with_stdio(0);
	cin.tie(0); cout.tie(0);
	int n, t,o;///n长度,m颜色数,o操作数
	cin>>n>>t>>o;
	build(1,n,1);
    while(o--)
    {
        char str;
        cin>>str;
        int lll,rrr,co;
        cin>>lll>>rrr;
        if(lll>rrr)swap(lll,rrr);
        if(str=='C')
        {
			cin >> co;
			update(1, n, 1, lll, rrr, co);
        }
        else
        {
            int ans=query(1, n, 1, lll, rrr);
			int cnt=0;
            cnt=__builtin_popcount(ans);///获取某个数二进制位1的个数
            cout<<cnt<<endl;
        }
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值