Maven 无效的目标发行版 无效的标记 idea的maven版本与cmd中maven的Java版本不一致

这个问题搞了我两天,是真的恶心至极!

从我这两天在网上搜索来看,这个问题90%都是因为JDK的版本不一致导致的。

一开始我也按照 该方法 一步步尝试,但是没有效果。 但其实不是该方法无效, 是我在按该方法完成后,突然发现我在cmd 里面查看maven的java版本是1.8,但是我在idea的终端命令窗口执行mvn -v 发现idea中查看maven的版本是1.7!!直到重启电脑后,idea终端和cmd中maven的java版本号才是一致。。。。

在这里插入图片描述
在这里插入图片描述

原因就在这,我以为修改了jdk的环境变量,并且再cmd中查看maven的java版本是正确后,就万事大吉了。万万没想到,还是得靠重启。

解决办法:
修改jdk环境变量,使其和所需要compile的项目jdk版本保持一致。
重启电脑。 如果不行请按 该文章中的步骤 尝试一遍之后在重启。

相关推荐
©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页