人见人爱A^B
Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
Sample Input
2 3
12 6
6789 10000
0 0
Sample Output
8
984
1
Author
lcy
Source
ACM程序设计期末考试(2006/06/07)
解题思路
每次自乘后取后三位
AC
#include<stdio.h>
using namespace std;
int main() {
int A, B;
while (scanf("%d %d", &A, &B) != EOF && (A != 0 || B != 0)) {
int ans = 1;
while (B--) {
ans *= A;
ans %= 1000;
}
printf("%d\n", ans);
}
return 0;
}