HDOJ 2058

The sum problem

Problem Description
Given a sequence 1,2,3,…N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input
20 10
50 30
0 0

Sample Output
[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]

Author
8600

Source
校庆杯Warm Up

解题思路
1.暴力求解
超时,开始思考别的方式。

#include<stdio.h>
using namespace std;
int main() {
	int n,m,cnt,pt;
	while (scanf("%d %d", &n, &m) != EOF && n != 0 && m!= 0) {
		for (int i = 1; i <= n; i++) {
			cnt = 0;
			pt = i;
			while (pt <= n && cnt < m) {
				cnt += pt++;
			}
			if (cnt == m)
				printf("[%d,%d]\n", i, pt-1);
		}
		printf("\n");
	}
	return 0;
}

2.通过等差数列的求和方式简化
将计算公式更换为等差数列的求和公式。超时。

#include<stdio.h>
using namespace std;
int main() {
	int n, m, lenth;
	while (scanf("%d %d", &n, &m) != EOF && n != 0 && m != 0) {
		for (int i = 1; i <= n; i++) {
			lenth = n;
			while ((2 * i + lenth - 1) * lenth / 2 > m) {
				lenth--;
			}
			if ((2 * i + lenth - 1) * lenth / 2 == m)
				printf("[%d,%d]\n", i, i + lenth - 1);
		}
		printf("\n");
	}
	return 0;
}

3.通过公式推导得到时间复杂度为O(n)的方式
设起点为i,长度为lenth,根据等差数列求和公式,易得:

(i+i+lenth-1)*lenth/2=m

经过变换得到

lenth*lenth+(2i-1)*lenth=2m

由于i>=1从而得知

lenth<sqrt(2m)

在lenth、m的值确定的情况下可以直接计算i,从而在满足条件的情况下直接输出范围即可。

AC

#include<stdio.h>
#include<math.h>
using namespace std;
int main() {
	int n, m, lenth,i;
	while (scanf("%d %d", &n, &m) != EOF && n != 0 && m != 0) {
		int lenth = sqrt(2 * m);
		while (lenth>0) {
			i = (2 * m / lenth + 1 - lenth) / 2;
			if((2*i+lenth-1)*lenth/2==m)
				printf("[%d,%d]\n", i, i + lenth - 1);
			lenth--;
		}
		printf("\n");
	}
	return 0;
}
  • 14
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值