Puzzle Pieces

You are given a special jigsaw puzzle consisting of n⋅mn⋅m identical pieces. Every piece has three tabs and one blank, as pictured below.
在这里插入图片描述

The jigsaw puzzle is considered solved if the following conditions hold:

The pieces are arranged into a grid with nn rows and mm columns.
For any two pieces that share an edge in the grid, a tab of one piece fits perfectly into a blank of the other piece.
Through rotation and translation of the pieces, determine if it is possible to solve the jigsaw puzzle.

Input

The test consists of multiple test cases. The first line contains a single integer tt (1≤t≤10001≤t≤1000) — the number of test cases. Next tt lines contain descriptions of test cases.

Each test case contains two integers nn and mm (1≤n,m≤1051≤n,m≤105).

Output

For each test case output a single line containing “YES” if it is possible to solve the jigsaw puzzle, or “NO” otherwise. You can print each letter in any case (upper or lower).

Sample Input

3
1 3
100000 100000
2 2

Sample Output

YES
NO
YES

Note

For the first test case, this is an example solution:
在这里插入图片描述

For the second test case, we can show that no solution exists.

For the third test case, this is an example solution:

在这里插入图片描述

题目大意:

问是否可以将拼图拼成n*m的矩形

解题思路:

①只有一排时,长度是任意的
②当排列为 2*2 时, 8个角都是向外凸起的,此时不能再放拼图

代码如下:
#include<iostream>
#include<algorithm>
#include<cstdio>

using namespace std;

int main()
{
	int t,n,m;
	scanf("%d",&t);
	while(t--){
		scanf("%d %d",&n,&m);
		if(n==1||m==1||(n==2&&m==2)) 
			printf("YES\n");
		else 
			printf("NO\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值