A1035 Password

问题描述

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase).
One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

输入格式

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

输出格式

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

输入样例1

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
(结尾无空行)

输出样例1

2
Team000002 RLsp%dfa
Team000001 R@spodfa
(结尾无空行)

输入样例2

1
team110 abcdefg332
(结尾无空行)

输出样例2

There is 1 account and no account is modified
(结尾无空行)

输入样例3

2
team110 abcdefg222
team220 abcdefg333
(结尾无空行)

输出样例3

There are 2 accounts and no account is modified
(结尾无空行)

C语言代码

#include<stdio.h>
#include<string.h>

//结构体存放修改后的用户信息
struct User{
	char name[15];
	char password[15];
}user[1010];

int main(){
	int n, count = 0; //count记录修改的用户信息数
	char name[15], password[15];
	scanf("%d", &n);
	
    //循环输入用户信息
	for(int j = 0; j < n; j++){
		bool jud = false; //判断是否进行了修改操作
		scanf("%s%s", name, password);	
	//遍历数组password,找到需要修改的部分
		for(int i = 0; i < strlen(password); i++){
			if(password[i] == '1'){
				password[i] = '@';
				jud = true;
			}
			else if(password[i] == '0'){
				password[i] = '%';
				jud = true;
			}
			else if(password[i] == 'l'){
				password[i] = 'L';
				jud = true;
			}
			else if(password[i] == 'O'){
				password[i] = 'o';
				jud = true;
			}
		}
	//如果进行了修改,则将信息存放在用户数组中
		if(jud){ 
			strcpy(user[count].name , name);
			strcpy(user[count].password , password);
			count++;
		}
	}
   //当没有修改记录时
	if(count == 0){
        if(n==1)
            printf("There is %d account and no account is modified", n);
        else
            printf("There are %d accounts and no account is modified", n);
    }
	else 
		printf("%d\n", count);
	for(int i = 0; i < count; i++){
		if(i != count-1)
			printf("%s %s\n", user[i].name, user[i].password);
		else
			printf("%s %s", user[i].name, user[i].password);
	}
	return 0;
}

注意:

  1. 阅读题目时,看清楚题目需求,情况要分类完全,例如有无修改信息、无修改信息,但n单复数不同时等多种情况

Password原题

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值