大小写字母互换/求字母的个数/首字母大写

大小写字母互换

描述
把一个字符串中所有出现的大写字母都替换成小写字母,同时把小写字母替换成大写字母。
输入
输入一行:待互换的字符串。
输出
输出一行:完成互换的字符串(字符串长度小于80)
样例输入
If so, you already have a Google Account. You can sign in on the right.
样例输出
iF SO, YOU ALREADY HAVE A gOOGLE aCCOUNT. yOU CAN SIGN IN ON THE RIGHT.

#include<iostream>
using namespace std;
int main()
{
    char a[80];
    cin.get(a,80);
    int i;
    for(i=0;a[i]!='\0';i++)
    {
        if(a[i]>='A'&&a[i]<='Z')
            a[i]=a[i]+32;
        else if(a[i]>='a'&&a[i]<='z')
            a[i]=a[i]-32;
    }
    cout<<a<<endl;
}

求字母的个数

描述
在一个字符串中找出元音字母a,e,i,o,u出现的次数。
输入
输入一行字符串(字符串中可能有空格,请用gets(s)方法把一行字符串输入到字符数组s中),字符串长度小于80个字符。
输出
输出一行,依次输出a,e,i,o,u在输入字符串中出现的次数,整数之间用空格分隔。
样例输入
If so, you already have a Google Account. You can sign in on the right.
样例输出
5 4 3 7 3
提示
注意,只统计小写元音字母a,e,i,o,u出现的次数。

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    char str[80];
    int a=0,e=0,i=0,o=0,u=0;
    gets(str);
    int j;
    for(j=0;str[j]!='\0';j++)
    {
        if(str[j]=='a')a++;
        else if(str[j]=='e') e++;
        else if(str[j]=='i') i++;
        else if(str[j]=='o') o++;
        else if(str[j]=='u') u++;

    }
    cout<<a<<' '<<e<<' '<<i<<' '<<o<<' '<<u<<' '<<endl;

}

首字母大写
描述
对一个字符串中的所有单词,如果单词的首字母不是大写字母,则把单词的首字母变成大写字母。在字符串中,单词之间通过空白符分隔,空白符包括:空格(’ ‘)、制表符(’\t’)、回车符(’\r’)、换行符(’\n’)。
输入
输入一行:待处理的字符串(长度小于80)。
输出
输出一行:转换后的字符串。
样例输入
if so, you already have a google account. you can sign in on the right.
样例输出
If So, You Already Have A Google Account. You Can Sign In On The Right.

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    char str[80];
    gets(str);
    int i;
    for(i=0;str[i+1]!='\0';i++)
    {
        if((str[i]==' '||str[i]=='\t'||str[i]=='\r'||str[i]=='\n')&&str[i+1]>='a'&&str[i+1]<='z')
            str[i+1]=str[i+1]-32;
    }
    if(str[0]>='a'&&str[0]<='z') str[0]=str[0]-32;
    cout<<str<<endl;

}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值