【数据结构】NOJ001 顺序表的插入运算

1. 题目

在这里插入图片描述

示例输入
7
2 3 4 5 6 7 8
1
示例输出
1 2 3 4 5 6 7 8

2. 代码

//7
//2 3 4 5 6 7 8
//1

#include <iostream>
#include <malloc.h>

using namespace std; 

typedef struct node{
	int data;
	struct node *next;
}Node;

void createList(Node *head, int n);
void insertList(Node *head, int x);
void outputList(Node *head);

int main(int argc, char** argv) {
	int elenum, x;
	cin >> elenum;
	Node *head;
	head = (Node*) malloc(sizeof(Node));
	createList(head, elenum);
	cin >> x;
	insertList(head, x);
	outputList(head);
	return 0;
}

void createList(Node *head, int n){
	Node *p;
	p = (Node*) malloc(sizeof(Node));
	p = head;
	for(int i=0; i<n; i++){
		p->next = (Node*) malloc(sizeof(Node));
		cin >> p->next->data;
		p = p->next;
	}
	p->next = NULL;
}

void insertList(Node *head, int x){
	Node *p, *px;
	p = head;
	px = (Node*) malloc(sizeof(Node));
	px->data = x;
	while(p->next){
		if(p->data >= x){
			px->next = p->next;
			p->next = px;
			return;
		}
		else{
			p = p->next;
		}
	}
	p->next = px;
	px->next = NULL;
}

void outputList(Node *head){
	Node *p;
	p = head->next;
	while(p){
		cout << p->data << " "; 
		p = p->next;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值