7-11 后缀式求值 (25 分)

88 篇文章 5 订阅
7 篇文章 0 订阅

我们人类习惯于书写“中缀式”,如 3 + 5 * 2 ,其值为13。 (p.s. 为什么人类习惯中缀式呢?是因为中缀式比后缀式好用么?)
而计算机更加习惯“后缀式”(也叫“逆波兰式”,Reverse Polish Notation)。上述中缀式对应的后缀式是: 3 5 2 * +
现在,请对输入的后缀式进行求值。
输入格式:

在一行中输入一个后缀式,运算数和运算符之间用空格分隔,运算数长度不超过6位,运算符仅有+ - * / 四种。
输出格式:

在一行中输出后缀式的值,保留一位小数。
输入样例:

3 5.4 2.2 * +

输出样例:

14.9

不确定是不是满分,我没提交过

#include <iostream>
#include <string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include <vector>
#include <map>
#include<queue>
using namespace std;
int main() {
	ios::sync_with_stdio(false);
	stack<double>st;
    string s;
    getline(cin,s);
    string temp;
    for(int i=0;i<s.size();i++){
    	if(s[i]==' '){
    		continue;
		}
    	if(isdigit(s[i])){
    		temp=s[i];
			while(isdigit(s[i+1])||s[i+1]=='.'){
				temp+=s[i+1];
				i++;
			}
			st.push(stod(temp));
		}
		else if(s[i]=='+'&&isdigit(s[i+1])){
			continue;
		}
		else if(s[i]=='-'&&isdigit(s[i+1])){
			temp=s[i];
			while(isdigit(s[i+1])||s[i+1]=='.'){
				temp+=s[i+1];
				i++;
			}
			st.push(stod(temp));
		}
		else{
			if(s[i]=='+'){
				double t2=st.top();
				st.pop();
				double t1=st.top();
				st.pop();
				st.push(t1+t2);
			}
			else if(s[i]=='-'){
				double t2=st.top();
				st.pop();
				double t1=st.top();
				st.pop();
				st.push(t1-t2);
			}
			else if(s[i]=='*'){
				double t2=st.top();
				st.pop();
				double t1=st.top();
				st.pop();
				st.push(t1*t2);
			}
			else if(s[i]=='/'){
				double t2=st.top();
				st.pop();
				double t1=st.top();
				st.pop();
				if(!t2){
				cout<<"ERROR";
				return 0;
				}
				st.push(t1/t2);
			}
		}
	}
	if(!st.empty()){
		printf("%.1f",st.top());
	}
    return 0;	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值