1061 Dating (20 分)

360 篇文章 3 订阅
91 篇文章 1 订阅

Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
结尾无空行
Sample Output:
THU 14:04
结尾无空行

本题其实很好理解,但是想拿满分是不容易的,因为有很多坑:
第一个坑,星期的大写字母只能从 A - G ,其他大写字母是不行的
第二个坑,月份的大写字母只能从 A -N 或者 0 - 9,其他是不行的
第三个坑,最后的日子只能是字母,不能是符号
第四个坑,周二与周四的英文很相似,建议复制防止打错

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
int main() {
	string s[7] = {"MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN"};
	string s1, s2;
	string c1, c2;
	cin >> s1 >> s2 >> c1 >> c2;
	bool first = false;
	for (int i = 0; i < min(s1.size(), s2.size()); i++) {
		if (s1[i] == s2[i]) {
			if (!first) {
				if (s1[i] >= 'A' && s1[i] <= 'G') {
					first = 1;
					cout << s[s1[i] - 'A'] << " ";
				}
			}
			else {
				if (s1[i] >= 'A'&&s1[i] <= 'N') {
					printf("%02d:", s1[i] - 'A' + 10);
					break;
				}
				else if (isdigit(s1[i])) {
					printf("%02d:", s1[i] - '0');
					break;
				}
			}
		}
	}
	for (int i = 0; i < min(c1.size(), c2.size()); i++) {
		if (c1[i] == c2[i] && isalpha(c1[i])) {
			printf("%02d", i);
			break;
		}
	}
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值