1117 Eddington Number (25 分)

360 篇文章 3 订阅
91 篇文章 1 订阅
这篇博客介绍了英国天文学家爱丁顿定义的'Eddington number',即骑行超过E英里的最多天数。通过输入连续骑行的天数及每天的骑行距离,程序计算并输出相应的E值。示例中给出了10天的骑行数据,经过排序后,找到满足条件的最大E值为6。
摘要由CSDN通过智能技术生成

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.

Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10
5
), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:
For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

结尾无空行
Sample Output:

6

从大到小排序,结果:
10 9 8 8 7 7 6 6 3 2
大于 10 的有 0 天,大于 9 的有 1 天,大于 8 的有两天以此列推,知道找到相等的

#include<iostream>
#include<bits/stdc++.h>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<deque>
#include<unordered_set>
#include<unordered_map>
#include<cctype>
#include<algorithm>
#include<stack>
using namespace std;
const int N = 100001;
int a[N];
int main() {
	int n, e = 0;
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin >> a[i];
	}
	sort(a, a + n, greater<int>());
	while (e < n && a[e] > e + 1) e++;
	cout << e;
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值