暑期训练2:AtCoder Beginner Contest 208 A Rolling Dice

A - Rolling Dice /
Time Limit: 2 sec / Memory Limit: 1024 MB

Score :
100
points

Problem Statement
Is it possible to get a sum of
B
when throwing a die with six faces
1
,
2
,

,
6

A
times?

Constraints
1

A

100
1

B

1000
A
and
B
are integers.
Input
Input is given from Standard Input in the following format:

A

B

Output
If it is possible to get a sum of
B
, print Yes; otherwise, print No.

Sample Input 1
Copy
2 11
Sample Output 1
Copy
Yes
There are two ways to get a sum of
11
when throwing a
6
-faced die twice:

getting
6
in the first throw and
5
in the second throw;
getting
5
in the first throw and
6
in the second throw.
Sample Input 2
Copy
2 13
Sample Output 2
Copy
No
There is no way to get a sum of
13
when throwing a
6
-faced die twice.

Sample Input 3
Copy
100 600
Sample Output 3
Copy
Yes
题解:很简单,本题就是问的是给定 a和 b,是否存在a次1~6数字的加和,能够和b数是相等的,相等的话输出Yes,反之则输出No。特别注意的是,我们发现此时这个AtCoder中不像codeforces中对于Yes和No中不区分大小写。

#include<bits/stdc++.h>
using namespace std;
int main()
{
  int a,b;
  cin>>a>>b;
  if(a<=b&&b<=6*a)
    cout<<"Yes"<<endl;
  else
    cout<<"No"<<endl;
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值