Oil Deposits 油藏

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
某地质调查公司负责探测地下石油矿床。该公司一次处理一个大的矩形区域,并创建一个网格,将土地划分为多个方形地块。然后分别分析每个地块,利用传感设备确定地块是否含油。含有石油的地块被称为“口袋”。如果两个油槽相邻,则它们是同一个油槽的一部分。石油储量可能相当大,并且可能包含许多小袋。你的工作是确定网格中包含多少不同的石油沉积物。

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.
输入文件包含一个或多个网格。每个网格从一行开始,其中包含m和n,即网格中的行数和列数,用单个空格分隔。如果m=0,则表示输入结束;否则1<=m<=100和1<=n<=100。接下来是m行,每行n个字符(不包括行尾字符)。每个字符对应一个绘图,要么是*',表示无油,要么是@’,表示油袋。

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
对于每个网格,输出不同石油沉积物的数量。如果两个不同的油腔水平、垂直或对角相邻,则它们是同一油藏的一部分。一个储油池的容量不会超过100个。

Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0
Sample Output
0
1
2
2

题解:
遇到’@‘,判断八个方向,并做好标记,防止重复,直到八个方向没有’@‘,则算作1个。

#include<iostream>
using namespace std;
char a[105][105];
int n,m;
void fx(int x,int y){
	int b[8][2]={{1,1},{1,0},{1,-1},{0,1},{0,-1},{-1,1},{-1,0},{-1,-1}}; 
	  //八个方向
	if(a[x][y]=='@'&&x<n&&x>=0&&y<m&&y>=0)  //范围限制
		{
			a[x][y]='*';   //标记
			for(int i=0;i<8;++i)
			    fx(b[i][0]+x,b[i][1]+y);  //横、纵坐标
		 } 
}
int main()
{
	while(cin>>n>>m){
		if(n==0&&m==0) break;
		int sum=0;
		for(int i=0;i<n;++i){
			cin>>a[i];
		}
		for(int i=0;i<n;++i){
			for(int j=0;j<m;++j){
			    if(a[i][j]=='@'){
			    	sum++;
			    	fx(i,j);
				}	
			}
		}
		cout<<sum<<endl;
	}
	return 0;
 } 
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值