算法03——PATA1042 Shuffing Machine

题目描述:Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:S1,S2,…S13,H1,H2,…H13,C1,C2,…C13,D1,D2,…D13,J1,J2。where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13。

输入格式:Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

输出格式:For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

样例输入:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

样例输出:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

思路:

  • 由于要进行k次洗牌,那么每一轮中,涉及到排序前,以及排序后,那么就可以设置start[N],end[N]两个数组
  • 由于结果输出要和花色对应,每种花色有13张牌,不妨用一个char型数组m[]={S,H,C,D,J},建立数组下标和对应花色的关系,如当前数组下标也就是牌号为x,那么对应的花色为m[(x-1)/13]

代码:

#include<stdio.h>

char m[5]={'S','H','C','D','J'};//牌的编号与花色的对应关系
int N = 54;//总共有54张牌
int start[55],next[55],end[55];

int main(){
    int time;
    scanf("%d",&time);
    int i;
    for(i = 1 ; i <= N ; i++)//初始化牌号
        start[i]=i;
    for(i = 1 ; i <= N ;i++)
        scanf("%d",&next[i]);
    while(time--){
        for(i=1;i<=N;i++){
            end[next[i]]=start[i];
        }
        for(i=1;i<=N;i++)
            start[i] = end[i];
    }
    for(i=1;i<=N;i++){
        if(i!=1)
            printf(" ");
        start[i]--;
        printf("%c%d",m[start[i]/13],start[i]%13+1);
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值