又是最短路问题 POJ - 1797

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4
背景 雨果很高兴。货物升降机项目失败后,他现在可以扩大业务。但他需要一个聪明的人告诉他,是否真的有一条路可以从他的客户建造的巨型钢吊到所有街道都能承受重量的地方。 幸运的是,他已经有了一个城市规划,包括所有街道和桥梁以及所有允许的重量。不幸的是,他不知道如何找到最大重量,以便告诉他的客户起重机可能变得有多重。但你肯定知道。 问题 你得到了城市的平面图,由交叉口之间的街道(有重量限制)描述,编号从1到n。你的任务是找到从交叉口1(雨果的地方)到交叉口n(顾客的地方)的最大重量。你可以假设至少有一条路。所有街道都可以双向行驶。
即求n = 1的点到 n = n 的所有可达路径中(当前路径权值最小的)最大值

#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
#define MAX 0x3f3f3f3f
const int maxn=1005;
int dis[maxn];
int map[maxn][maxn];
bool book[maxn];
int n;
void spfa(int x)
{
    queue<int>Q;
    while(!Q.empty())
    {
        Q.pop();
    }
    memset(dis,0,sizeof(dis));
    memset(book,false,sizeof(book));
    book[x]=true;
    dis[x]=MAX;
    Q.push(x);
    int t;
    while(!Q.empty())
    {
        t=Q.front();
        Q.pop();
        book[t]=false;
        for(int i=1; i<=n; i++)
        {
            if(dis[i]<min(dis[t],map[t][i]))
            {
                dis[i]=min(dis[t],map[t][i]);
                if(!book[i])
                {
                    Q.push(i);
                    book[i]=true;
                }
            }

        }
    }
}
int main()
{
    int a,b,x,y,m,num=0;
    scanf("%d",&a);
    while(a--)
    {
        scanf("%d%d",&n,&m);
        memset(map,0,sizeof(map));
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&x,&y,&b);
            map[x][y]=map[y][x]=b;
        }
        spfa(1);
        num++;
        printf("Scenario #%d:\n",num);
        printf("%d\n\n",dis[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值