PAT(甲级)2017年春季考试 PAT 1127 ZigZagging on a Tree (30 分) 二叉树

21 篇文章 1 订阅

PAT(甲级)2017年春季考试
PAT 1127 ZigZagging on a Tree (30 分) 二叉树

【题目描述】
Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

【解题思路】

经典的二叉树问题

输入给出二叉树的中序遍历后序遍历,要求输出层序遍历

输出还有个要求,按照“Z”字形,奇数层从右往左,偶数层从左往右(这里把根节点作为第1层)。

我们在BFS层序遍历的时候,将每一层的结点存入vector中,输出的时候按照层数的奇偶来输出就可以了。

【满分代码】

#include <iostream>
#include <cstdio>
#include <queue>
#include <vector>
using namespace std;
int in[35],post[25];
vector<int> vec[35];
struct node
{
	int data;
	node *lchild,*rchild;
};
node* build(int postL,int postR,int inL,int inR)
{
	if(postL>postR)
		return NULL;
	node *root=new node;
	root->data=post[postR];
	int k;
	for(k=inL;k<=inR;k++)
		if(in[k]==post[postR])
			break;
	int num=k-inL;
	root->lchild=build(postL,postL+num-1,inL,k-1);
	root->rchild=build(postL+num,postR-1,k+1,inR);
	return root;
}//递归建二叉树 
void BFS(node* root)
{
	cout<<root->data;//输出根节点的值 
	queue<node*> q;
	q.push(root);
	int level=0;//当前层数(根节点为第1层) 
	while(!q.empty())
	{
		level++;
		int size=q.size();//当前层上的结点个数 
		while(size--)
		{
			node* t=q.front();
			q.pop();
			vec[level].emplace_back(t->data);
			if(t->lchild)
				q.push(t->lchild);
			if(t->rchild)
				q.push(t->rchild);
		}
	}
	for(int i=2;i<=level;i++)
	{
		if(i%2==0)//偶数层从左往右输出 
		{
			for(int j=0;j<vec[i].size();j++)
				cout<<" "<<vec[i][j];
		}
		else//奇数层从右往左输出 
		{
			for(int j=vec[i].size()-1;j>=0;j--)
				cout<<" "<<vec[i][j];
		}
	}
}//层序遍历并输出 
int main()
{
	ios::sync_with_stdio(0),cin.tie(0),cout.tie(0);
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
		cin>>in[i];
	for(int i=0;i<n;i++)
		cin>>post[i];
	node *root=build(0,n-1,0,n-1);
	BFS(root);
	return 0; 
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

球王武磊

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值