HDU-2717:Catch That Cow

传送门
Problem Description

Farmer John has been informed of the location of a fugitive cow and
wants to catch her immediately. He starts at a point N (0 ≤ N ≤
100,000) on a number line and the cow is at a point K (0 ≤ K ≤
100,000) on the same number line. Farmer John has two modes of
transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long
does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John
to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move
along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<iostream>
#include<stdio.h>
#include<string>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
bool line[100001];
int bfs(int n, int k)
{
	memset(line, 0, sizeof(line));
	queue<pair<int, int>>farmer;
	farmer.push(make_pair(n,0));
	line[n] = 1;
	while (!farmer.empty())
	{
		pair<int, int>head = farmer.front();
		farmer.pop();
		if (head.first == k)
			return head.second;
		if (head.first - 1 <= 100000 && head.first - 1 >= 0 && line[head.first - 1] == 0)
		{
			farmer.push(make_pair(head.first - 1, head.second + 1));
			line[head.first - 1] = 1;
		}
		if (head.first + 1 <= 100000 && head.first + 1 >= 0 && line[head.first + 1] == 0)
		{
			farmer.push(make_pair(head.first + 1, head.second + 1));
			line[head.first + 1] = 1;
		}
		if (head.first * 2 <= 100000 && head.first * 2 >= 0 && line[head.first * 2] == 0)
		{
			farmer.push(make_pair(head.first * 2, head.second + 1));
			line[head.first * 2] = 1;
		}
	}
}
int main()
{
	int N, K;
	while (cin >> N >> K)
		cout << bfs(N, K) << endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

艺千秋录

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值