POJ-6187:Destroy Walls(最大生成树)

传送门
Problem Description
Long times ago, there are beautiful historic walls in the city. These walls divide the city into many parts of area.

Since it was not convenient, the new king wants to destroy some of these walls, so he can arrive anywhere from his castle. We assume that his castle locates at (0.6∗2√,0.6∗3√).

There are n towers in the city, which numbered from 1 to n. The ith’s location is (xi,yi). Also, there are m walls connecting the towers. Specifically, the ith wall connects the tower ui and the tower vi(including the endpoint). The cost of destroying the ith wall is wi.

Now the king asks you to help him to divide the city. Firstly, the king wants to destroy as less walls as possible, and in addition, he wants to make the cost least.

The walls only intersect at the endpoint. It is guaranteed that no walls connects the same tower and no 2 walls connects the same pair of towers. Thait is to say, the given graph formed by the walls and towers doesn’t contain any multiple edges or self-loops.

Initially, you should tell the king how many walls he should destroy at least to achieve his goal, and the minimal cost under this condition.

Input
There are several test cases.
For each test case:
The first line contains 2 integer n, m.
Then next n lines describe the coordinates of the points.
Each line contains 2 integers xi,yi.
Then m lines follow, the ith line contains 3 integers ui,vi,wi
|xi|,|yi|≤105
3≤n≤100000,1≤m≤200000
1≤ui,vi≤n,ui≠vi,0≤wi≤10000

Output
For each test case outout one line with 2 integers sperate by a space, indicate how many walls the king should destroy at least to achieve his goal, and the minimal cost under this condition.

Sample Input
4 4
-1 -1
-1 1
1 1
1 -1
1 2 1
2 3 2
3 4 1
4 1 2

Sample Output
1 1

#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
using namespace std;
#define SIZE 200005
#define N 200005
struct Edge
{
	int u, v;//连接的两座城市
	int cost;//花销
}EdgeArray[SIZE];
int Father[N];
bool cmp(Edge a, Edge b)
{
	return a.cost > b.cost;
}

int Find(int x)
{
	return Father[x] == x ? x : Father[x] = Find(Father[x]);
}

bool Union(int x, int y)
{
	int x1 = Find(x);
	int y1 = Find(y);
	if (x1 != y1)
	{
		Father[x1] = y1;
		return true;
	}
	return false;
}


int main()
{
	int n, m;
	int x, y;
	while (~scanf("%d%d", &n, &m))
	{
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &x, &y);
			Father[i] = i;//初始化根节点为本身
		}
		int sum = 0;
		for (int i = 1; i <= m; i++)
		{
			scanf("%d%d%d", &EdgeArray[i].u, &EdgeArray[i].v, &EdgeArray[i].cost);
			sum += EdgeArray[i].cost;
		}
		sort(EdgeArray + 1, EdgeArray + m + 1, cmp);//按花销由高到低排序
		int Cost = 0, num = 0;
		for (int i = 1; i <= m; i++)
		{
			if (Union(EdgeArray[i].u, EdgeArray[i].v))
			{
				Cost += EdgeArray[i].cost;
				num++;
			}
		}
		cout << m - num << " " << sum - Cost << endl;
		//printf("%d %d\n", m - num, sum - Cost);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

艺千秋录

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值