P3131 [USACO16JAN]Subsequences Summing to Sevens S

13 篇文章 0 订阅
12 篇文章 0 订阅

P3131 [USACO16JAN]Subsequences Summing to Sevens S

题目描述

Farmer John’s NN cows are standing in a row, as they have a tendency to do from time to time. Each cow is labeled with a distinct integer ID number so FJ can tell them apart. FJ would like to take a photo of a contiguous group of cows but, due to a traumatic childhood incident involving the numbers 1 \ldots 61…6, he only wants to take a picture of a group of cows if their IDs add up to a multiple of 7.
Please help FJ determine the size of the largest group he can photograph.
给你n个数,分别是a[1],a[2],…,a[n]。求一个最长的区间[x,y],使得区间中的数(a[x],a[x+1],a[x+2],…,a[y-1],a[y])的和能被7整除。输出区间长度。若没有符合要求的区间,输出0。

输入格式:

The first line of input contains NN (1≤N≤50,000). The next NN
lines each contain the N integer IDs of the cows (all are in the range
0 …1,000,000).
输出格式:

Please output the number of cows in the largest consecutive group whose IDs sum
to a multiple of 7. If no such group exists, output 0.

样例输入 Copy

5 4
2 2 1 0
3 3 1 1
4 4 1 0
3 3 2 1

样例输出 Copy

5

思路

这题其实一开始没有想出来怎么计算,虽然之前学过前缀和,但是可能学的不是很好吧(本人知识有限),还是看了洛谷题解里才知道的,若两个数相减%7==0,那么这两个数%7的余数一定相同!!
知道这点以后就可以开始快乐的敲代码了,只要每次计算前缀和的时候%7就可以解决数据超出INT的情况,在设置两个数组start和end,一个用来计算每个余数第一次出现的位置,一个用来计算最后一次出现的位置。

AC代码

#include<bits/stdc++.h>
using namespace std;
int start[10],end[10];
int s[50005];
int main(){
	int n;
	memset(s,0,sizeof(s));
	cin >> n;
	for(int i = 1 ; i <= n ; i ++){
		cin >> s[i];
		s[i] = (s[i - 1] + s[i]) % 7; 
	}
	
	for(int i = 1 ; i <= n ; i ++){
		end[s[i]] = i;
	}
	
	for(int i = n ; i >= 1 ; i --){
		start[s[i]] = i;
	}
	int Max = 0;
	for(int i = 0 ; i < 7 ; i ++){
		Max = max(Max,end[i] - start[i]);
	}
	cout << Max << endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值