UVA-135(tarjan-割点)

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting
several places numbered by integers from 1 to N. No two places have the same number. The lines
are bidirectional and always connect together two places and in each place the lines end in a telephone
exchange. There is one telephone exchange in each place. From each place it is possible to reach
through lines every other place, however it need not be a direct connection, it can go through several
exchanges. From time to time the power supply fails at a place and then the exchange does not operate.
The officials from TLC realized that in such a case it can happen that besides the fact that the place
with the failure is unreachable, this can also cause that some other places cannot connect to each other.
In such a case we will say the place (where the failure occured) is critical. Now the officials are trying
to write a program for finding the number of all such critical places. Help them.
Input
The input file consists of several blocks of lines. Each block describes one network. In the first line
of each block there is the number of places N < 100. Each of the next at most N lines contains the
number of a place followed by the numbers of some places to which there is a direct line from this place.
These at most N lines completely describe the network, i.e., each direct connection of two places in
the network is contained at least in one row. All numbers in one line are separated by one space. Each
block ends with a line containing just ‘0’. The last block has only one line with N = 0.
Output
The output contains for each block except the last in the input file one line containing the number of
critical places.
Sample Input
5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0
Sample Output
1
2
题目大意:给出n个点和点与点的之间的连接,求在图中的去掉以后图不能联通的点,既割点。
输入:多组案例,每组第一行为点的个数.然后是起点,随后是相连的点的序号。以0为每组结束的标记。在一组结束后以0为案例结束的标记。
输出:割点的数目
样例一图形
样例
可以看出只有5为割点
样例二图形
样例二
可以看出只有2和5是割点
解题过程
先建图,由题意知要建无向图,然后用tarjan(dfs) 把图上的父子关系找好。
根据父子关系判断是否为割点。
割点有两种

  1. u为树根,且u有多于一个子树。
    (2) u不为树根,且满足存在(u,v)为树枝边(或称 父子边,即u为v在搜索树中的父亲),使得 dfn(u)<=low(v)。
    (也就是说 V 没办法绕过 u 点到达比 u dfn要小的点)
    注:这里所说的树是指,DFS下的搜索树
    代码(初学tarjan,参照某位大神的)
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <vector>
using namespace std;

#define N 10010
#define mem(a,b) memset(a,b,sizeof(a));
int dfn[N];  ///代表最先遍历到这个点的时间
int low[N];///这个点所能到达之前最早的时间点
int Father[N];///保存这个节点的父亲节点
int n,Time;
int cnt=0;
int head[N];
struct node
{
    int to;
    int next;
}edge[N];
void addedge(int to,int from)
{
    edge[cnt]={to,head[from]};
    head[from]=cnt++;
}

void init()
{
    mem(low,0);
    mem(dfn,0);
    mem(head,-1);
    mem(Father,0);
    Time=0;
    cnt=0;
}

void Tarjan(int u,int fa)
{
    low[u]=dfn[u]=++Time;
    Father[u]=fa;//保存父节点
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int to=edge[i].to;
        if(!dfn[to])//未遍历
        {
            Tarjan(to,u);
            low[u]=min(low[u],low[to]);
        }
        else if(fa!=to)//已遍历,看是否有其他路径
            low[u]=min(dfn[to],low[u]);
    }
}

void solve()
{
    int Rootson=0,ans=0;  ///根节点儿子的数量
    bool Cut[N]={false};///标记数组,判断这个点是否是割点


    Tarjan(1,0);

    for(int i=2;i<=n;i++)
    {
        int v=Father[i];
        if(v==1)  ///也是就说 i的父亲是根节点
            Rootson++;
        else if(dfn[v]<=low[i])  ///判断是否满足条件(2)
          {
              Cut[v]=true;
              //printf("%d %d ",v,i);
          }
    }
    for(int i=2;i<=n;i++)
    {
        if(Cut[i])
        {
            //printf("%d ",i);
            ans++;
        }
    }
    if(Rootson>1)  ///满足条件(1)
        ans++;
    printf("%d\n",ans);
}

int main()
{
    while(scanf("%d",&n),n)
    {
        int a,b;
        char ch;
        init();
        while(scanf("%d",&a),a)
        {
            while(scanf("%d%c",&b,&ch))
            {
                addedge(a,b);
                addedge(b,a);
                if(ch=='\n')
                    break;
            }
        }
        solve();
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值