给定一个长度为 n 的整数数列,请使用快速排序对这个数列按照从小到大进行排序,并将排好序的数列按顺序输出。
输入格式
输入共两行,第一行包含整数 n。
第二行包含 n 个整数(所有整数均在 1∼109 范围内),表示整个数列。
输出格式
输出共一行,包含 n 个整数,表示排好序的数列。
数据范围
1≤n≤100000
输入样例 :
5
3 1 2 4 5
输出样例 :
1 2 3 4 5
算法一:
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
int[] arr = new int[n];
for (int i = 0; i < n; i ++) {
arr[i] = sc.nextInt();
}
quick_sort(arr, 0, n - 1);
for (int j = 0; j < n; j ++) {
System.out.print(arr[j] + " ");
}
}
public static void quick_sort(int[] q, int l, int r) {
if (l >= r) return;
int i = l - 1, j = r + 1, x = q[(l + r)/2];
while (i < j) {
do i ++; while (q[i] < x);
do j --; while (q[j] > x);
if (i < j) {
int temp = q[i];
q[i] = q[j];
q[j] = temp;
}
}
quick_sort(q, l, j);
quick_sort(q, j+1, r);
}
}
算法二:
import java.io.*;
public class Main{
public static void main(String[] args) throws IOException{
BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
int n = Integer.parseInt(reader.readLine());
int[] arr = new int[n];
String[] strs = reader.readLine().split(" ");
for(int i = 0; i < n; i++){
arr[i] = Integer.parseInt(strs[i]);
}
quickSort(arr, 0, arr.length - 1);
for(int i = 0; i < arr.length; i++){
System.out.print(arr[i] + " ");
}
reader.close();
}
public static void quickSort(int[] arr, int start, int end){
if(start < end){
int low = start;
int high = end;
int started = arr[start];
while(low < high){
while(low < high && started <= arr[high]){
high--;
}
arr[low] = arr[high];
while(low < high && arr[low] <= started){
low++;
}
arr[high] = arr[low];
}
arr[low] = started;
quickSort(arr, start, low);
quickSort(arr, low+1 ,end);
}
}
}
两种方式在输入的时候有区别,以及在排序时定界的地方有区别,但是BufferedReader比Scanner的输入快好多倍,建议使用BufferedReader。