思科设备 HSRP 、 DHCP 、NAT 、ACL、STP 、OSPF 、链路捆绑技术的概述以及配置详解!!!!!

在这里插入图片描述
*HSRP概述:

  • -HSRP:热备份路由器协议
  • -HSRP是思科的私有协议,与VRRP功能类似
  • -HSRP不支持将真实的接口地址设置为虚拟的网关地址
  • -HSRP将报文承载在UDP报文上
  • -主要解决单点故障,用于核心层做负载负担

*DHCP概述:

  • -DHCP:动态主机配置协议
  • -用于实现企业用户IP地址的动态分配和集中管理
  • -避免繁琐的手工配置,快速适应网络的变化

*NAT概述:

  • -NAT:网络地址转换

  • -通常是配置在公网和私有网络的边界设备上, 具体是配置在连接公网的接口上;

  • -NAT的工作过程,完全是依靠 NAT 表,里面包含的是私有地址和公有地址的转换条目。

  • -NAT分为静态NAT和动态NAT

  • -静态NAT:

    -优点:简单方便,容易理解
    -缺点:一个私有地址,就必须占用/对应一个公网地址,不节省公网IP

  • -动态NAT:
    -优点:可以让多个私有地址循环使用少量的公网IP地址,都是自动形成对应关系
    -缺点:当内部网络主机数量很多的时候,依然无法满足大量主机上网,

*ACL概述:

  • -ACL:访问控制列表
  • -ACL的主要作用是用于控制设备之间的数据包的互通的;
  • -主要是通过检查数据包的3层IP头部和4层传输层协议的头部信息进行抓取数据包;
  • -针对于3层IP头部,ACL可以抓取数据包中的源IP地址、目标IP地址、协议号等字段;
  • -针对于4层传输层协议头部, ACL可以抓取数据包的源端口号、目标端口号;

*链路捆绑概述:

  • -链路捆绑 ,将多个物理线路捆绑成一个大带宽的逻辑线路,在设备看来是一个逻辑接口
  • 主要解决单点故障、链路带宽等问题
  • 链路捆绑分为动态和静态
  • 静态捆绑:
    -静态的捆绑链路的数量都参与数据转发
  • -动态捆绑
    -动态聚合可以从捆绑的链路数中选择活跃的接口

*STP概述:

  • -STP:生成树协议
  • –逻辑上断开环路,防止广播风暴的产生
  • -当线路故障,阻塞接口被激活,恢复通信,起备份线路的作用
  • -通过选举根网桥、根端口、指定端口来决定阻塞端口
  • -主要解决单点故障、二层环路等问题**

*OSPF概述:

  • -OSPF:开放的最短路径优先协议
  • -在路由器之间运行,主要是为了动态的互相学习路由条目
  • -属于动态路由协议的类型;
  • -公有的标准协议,任何厂商设备都支持
  • -OSPF的数据包是直接包含在IP头部后面的,协议号为 89
  • -OSPF的数据包的发送方式是组播,组播地址为:224.0.0.5和224.0.0.6

*实验需求:

  • -PC8不能访问服务器5的任何服务
  • -内网所有主机可以访问外网
  • -外部网络可以访问内网的服务器
  • -避免单点故障,配置冗余设备
  • -避免环路,配置STP,合理的选择根交换机
  • -除PC8,全网互通

*配置思路:

**基础配置 :**基础配置是VLAN 、接口、IP地址、路由的配置,就不做过多介绍了!!

交换机8(左):

Switch(config)#vlan 10
Switch(config)#interface range f0/1- 2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10

交换机9(右):

Switch(config)#vlan 20
Switch(config)#interface range f0/1- 2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10

多层交换机1(左):

Switch(config)#vlan 10
Switch(config)#vlan 20
Switch(config)#int vlan 10
Switch(config-if)#ip address 192.168.10.230 255.255.255.0

Switch(config)#int vlan 20
Switch(config-if)#ip address 192.168.20.230 255.255.255.0

Switch(config)#int f0/7
Switch(config-if)#no switchport
Switch(config-if)#ip address 10.10.10.1 255.255.255.0
Switch(config-if)#no shutdown

Switch(config)#ip routing ------------------------------------------------------------------------------------------------------开启路由

多层交换机2(右):

Switch(config)#vlan 10
Switch(config)#vlan 20
Switch(config)#int vlan 10
Switch(config-if)#ip address 192.168.10.240 255.255.255.0

Switch(config)#int vlan 20
Switch(config-if)#ip address 192.168.20.240 255.255.255.0

Switch(config)#int f0/7
Switch(config-if)#no switchport
Switch(config-if)#ip address 10.10.20.1 255.255.255.0
Switch(config-if)#no shutdown

Switch(config)#ip routing

边界路由器3(左):

Router(config)#int g0/0
Router(config-if)#ip address 10.10.10.2 255.255.255.0
Switch(config-if)#no shutdown

Router(config)#int g0/1
Router(config-if)#ip address 10.10.20.2 255.255.255.0
Switch(config-if)#no shutdown

Router(config)#int g0/2
Router(config-if)#ip address 100.1.1.1 255.255.255.0
Switch(config-if)#no shutdown

Router(config)#ip route 0.0.0.0 0.0.0.0 100.1.1.2 -----------------------------------------------------------写一条通往外网的默认路由

路由器4(右):

Router(config)#int g0/1
Router(config-if)#ip address 200.1.1.1 255.255.255.0
Router(config-if)#no shutdown

Router(config-if)#int g0/0
Router(config-if)#ip address 100.1.1.2 255.255.255.0
Router(config-if)#no shutdown

*链路捆绑配置:

交换机8(左):

Switch(config)#int range f0/3-4
Switch(config-if-range)#switchport mode trunk
------------------------------------------------------------------------先设为trunk模式
Switch(config-if-range)#channel-group 1 mode on --------------------------------------------------------------对这俩条链路进行捆绑

Switch(config)#int range f0/5-6
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#channel-group 2 mode on

交换机9(右):

Switch(config)#int range f0/3-4
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#channel-group 4 mode on

Switch(config)#int range f0/5-6
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#channel-group 3 mode on

多层交换机1(左):

Switch(config)#int range f0/1-2
Switch(config-if-range)#switchport trunk encapsulation dot1q
------------------------------------三层交换设备先设为dot1q封装协议
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#channel-group 1 mode on

Switch(config)#int range f0/3-4
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#channel-group 3 mode on

Switch(config)#int range f0/5-6
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#channel-group 5 mode on

多层交换机2(右):

Switch(config)#int range f0/1-2
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#channel-group 4 mode on

Switch(config)#int range f0/3-4
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#channel-group 2 mode
on

Switch(config)#int range f0/5-6
Switch(config-if-range)#switchport trunk encapsulation dot1q
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#channel-group 5 mode on

*STP配置:

多层交换机1(左):

Switch(config)#spanning-tree mode pvst --------------------------------------------------------设为pvst模式(思科设备默认为PVST)
Switch(config)#spanning-tree vlan 10 priority 4096 ---------------------------------------------将此交换机设为VLAN 10的根交换机
Switch(config)#spanning-tree vlan 20 priority 8192 ----------------------------------------------将此交换机设为VLAN 20的备根交换机

多层交换机2(右):

Switch(config)#spanning-tree mode pvst
Switch(config)#spanning-tree vlan 10 priority 8192
Switch(config)#spanning-tree vlan 20 priority 4096

*HSRP配置:

多层交换机1(左):

Switch(config)#int vlan 10
Switch(config-if)#standby 10 ip 192.168.10.254
---------------------------------------------------------------------配置虚拟网关
Switch(config-if)#standby 10 priority 200 --------------------------------------------------------将此交换机设为VLAN 10的主网关
Switch(config-if)#standby 10 preempt ------------------------------------------------------------------------------------开启抢占功能

Switch(config)#int vlan 20
Switch(config-if)#standby 20 ip 192.168.20.254
-----------------------------------------------------------------------------配置虚拟网关
Switch(config-if)#standby 20 priority 195 -----------------------------------------------------------------将此交换机设为VLAN 20的备份网关
Switch(config-if)#standby 20 preempt

多层交换机2(右):

Switch(config)#int vlan 10
Switch(config-if)#standby 10 ip 192.168.10.254

Switch(config-if)#standby 10 priority 195 ----------------------------------------------------------------------将此交换机设为VLAN 10的备份网关
Switch(config-if)#standby 10 preempt

Switch(config)#int vlan 20
Switch(config-if)#standby 20 ip 192.168.20.254

Switch(config-if)#standby 20 priority 200 --------------------------------------------------------------将此交换机设为VLAN 20的主网关
Switch(config-if)#standby 20 preempt

*DHCP配置:

多层交换机1(左):

Switch(config)#ip dhcp pool 1 --------------------------------------------------------------------------------------------------------创建地址池 1
Switch(dhcp-config)#network 192.168.10.0 255.255.255.0 ----------------------------------------------------------------------设置网段
Switch(dhcp-config)#default-router 192.168.10.254 ----------------------------------------------------------------------------设置网关
Switch(dhcp-config)# dns-server 8.8.8.8 -----------------------------------------------------------------------------------设置DNS

Switch(config)#ip dhcp pool 2
Switch(dhcp-config)#network 192.168.20.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.20.254
Switch(dhcp-config)# dns-server 8.8.8.8

Switch(config)#ip dhcp excluded-address 192.168.10.120 192.168.10.253 -----------------------------排除地址,避免与交换机2分配的地址冲突等隐患
Switch(config)#ip dhcp excluded-address 192.168.20.120 192.168.20.253

多层交换机2(右):

Switch(config)#ip dhcp pool 3
Switch(dhcp-config)#network 192.168.10.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.10.254
Switch(dhcp-config)# dns-server 8.8.8.8

Switch(config)#ip dhcp pool 4
Switch(dhcp-config)#network 192.168.20.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.20.254
Switch(dhcp-config)# dns-server 8.8.8.8

Switch(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.119 -----------------------------排除地址,避免与交换机1分配的地址冲突等隐患
Switch(config)#ip dhcp excluded-address 192.168.20.1 192.168.20.119

*OSPF配置:

多层交换机1(左):

Switch(config)#router ospf 10 --------------------------------------------------------------------创建OSPF进程
Switch(config-router)#log-adjacency-changes ------------------------------------------------激活路由协议邻接关系变化日志功能
Switch(config-router)#network 10.10.10.0 0.0.0.255 area 0 ------------------------------------------------------------------宣告路由
Switch(config-router)#network 192.168.0.0 0.0.255.255 area 0

多层交换机2(右):

Switch(config)#router ospf 10
Switch(config-router)#log-adjacency-changes
Switch(config-router)#network 10.10.20.0 0.0.0.255 area 0
Switch(config-router)#network 192.168.0.0 0.0.255.255 area 0

边界路由器3(左):

Switch(config)#router ospf 10
Switch(config-router)#log-adjacency-changes
Switch(config-router)#network 10.10.10.0 0.0.0.255 area 0
Switch(config-router)#network 10.10.20.0 0.0.0.255 area 0

Switch(config-router)#default-information originate -----------------------------------------------------引入默认路由

*ACL概述:

多层交换机2(右):

Switch(config)#access-list 100 deny ip host 192.168.20.121 host 192.168.10.1 -------------------------------禁止PC8访问服务器5的任何服务器(PC8通过DHCP获取到的地址是192.168.20.121,服务器5通过DHCP获取到的地址是192.168.10.1)
Switch(config)#access-list 100 permit ip any any

Switch(config)#int vlan 20
Switch(config-if)#ip access-group 100 in ----------------------------------在VLAN 20虚接口引入access-list 100

*NAT配置:

边界路由器3(左):

Switch(config)#access-list 10 permit any ----------------------------------创建一条标准ACL ,允许所有流量通过
Switch(config)#ip nat inside source list 10 interface GigabitEthernet0/2 overload ------------------------------------------------------配置地址转换,指向路由器的出接口

Switch(config)#ip nat inside source static tcp 192.168.10.1 80 100.1.1.10 80 ----------------------------------------------------配置私有地址和公有地址的映射
Switch(config)#ip nat inside source static tcp 192.168.20.120 80 100.1.1.20 80

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页