1095 解码PAT准考证 (25 分)

PAT 准考证号由 4 部分组成:

第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
第 2~4 位是考场编号,范围从 101 到 999;
第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
最后 11~13 位是考生编号,范围从 000 到 999。
现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

输入格式:
输入首先在一行中给出两个正整数 N(≤10
4
)和 M(≤100),分别为考生人数和统计要求的个数。

接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [0,100] 内的整数),其间以空格分隔。

考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

类型 为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的 指令 则给出代表指定级别的字母;
类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的 指令 则给出指定考场的编号;
类型 为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的 指令 则给出指定日期,格式与准考证上日期相同。
输出格式:
对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:

类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
类型 为 2 的指令,按 人数 总分 的格式输出;
类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。
如果查询结果为空,则输出 NA。

输入样例:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

输出样例:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
#include<bits/stdc++.h>
using namespace std;
struct student{
    string num;
    int score;
};

struct other{
    int num;
    string c;
};


struct man{
    string num;
    int score;
};


bool cmp(struct student s1,struct student s2){
    if(s1.score == s2.score) return s1.num < s2.num;
    return s1.score > s2.score;
}


int main(){
    int N,M;
    cin>>N>>M;
    struct student stu[N];
    struct other oth[M];
    for(int i=0;i<N;i++) cin>>stu[i].num>>stu[i].score;
    for(int i=0;i<M;i++) cin>>oth[i].num>>oth[i].c;


    for(int i=0;i<M;i++){
        vector<struct student> v;
        cout<<"Case "<<i+1<<": "<<oth[i].num<<" "<<oth[i].c<<endl;
        if(oth[i].num == 1){

            for(int j=0;j<N;j++){
                string temp = stu[j].num;
                if(temp.substr(0,1) == oth[i].c){
                    v.push_back(stu[j]);
                }
            }
            if(v.size() == 0){
                printf("NA\n");
                continue;
            }
                sort(v.begin(),v.end(),cmp);

                for(int i=0;i<v.size();i++){
                    printf("%s %d\n",v[i].num.c_str(),v[i].score);
                }

        }else if(oth[i].num == 2){
            int score = 0;
            for(int k=0;k<N;k++){
                string temp = stu[k].num;
                if(temp.substr(1,3) == oth[i].c){
                    v.push_back(stu[k]);
                    score += stu[k].score;
                }

            }
            if(v.size() == 0){
                printf("NA\n");
                continue;
            }
            printf("%d %d\n",v.size(),score);
        }else if(oth[i].num == 3){
                unordered_map<string,int> Map;
                for(int j=0;j<N;j++){
                string temp = stu[j].num;
                if(temp.substr(4,6) == oth[i].c){
                    Map[temp.substr(1,3)]++;
                }

            }

            for(auto x : Map){
                v.push_back({x.first,x.second});
            }

            if(v.size() == 0){
                printf("NA\n");
                continue;
            }

            sort(v.begin(),v.end(),cmp);

            for(int i=0;i<v.size();i++){
                printf("%s %d\n",v[i].num.c_str(),v[i].score);
            }



        }


    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值