Description
Recently you have bought a snow walking robot and brought it home. Suppose your home is a cell (0,0) on an infinite grid.
You also have the sequence of instructions of this robot. It is written as the string s consisting of characters ‘L’, ‘R’, ‘U’ and ‘D’. If the robot is in the cell (x,y) right now, he can move to one of the adjacent cells (depending on the current instruction).
If the current instruction is ‘L’, then the robot can move to the left to (x−1,y);
if the current instruction is ‘R’, then the robot can move to the right to (x+1,y);
if the current instruction is ‘U’, then the robot can move to the top to (x,y+1);
if the current instruction is ‘D’, then the robot can move to the bottom to (x,y−1).
You’ve noticed the warning on the last page of the manual: if the robot visits some cell (except (0,0)) twice then it breaks.
So the sequence of instructions is valid if the robot starts in the cell (0,0), performs the given instructions, visits no cell other than (0,0) two or more times and ends the path in the cell (0,0). Also cell (0,0) should be visited at most two times: at the beginning and at the end (if the path is empty then it is visited only once). For example, the following sequences of instructions are considered valid: “UD”, “RL”, “UUURULLDDDDLDDRRUU”, and the following are considered invalid: “U” (the endpoint is not (0,0)) and “UUDD” (the cell (0,1) is visited twice).
The initial sequence of instructions, however, might be not valid. You don’t want your robot to break so you decided to reprogram it in the following way: you will remove some (possibly, all or none) instructions from the initial sequence of instructions, then rearrange the remaining instructions as you wish and turn on your robot to move.
Your task is to remove as few instructions from the initial sequence as possible and rearrange the remaining ones so that the sequence is valid. Report the valid sequence of the maximum length you can obtain.
Note that you can choose any order of remaining instructions (you don’t need to minimize the number of swaps or any other similar metric).
You have to answer q independent test cases.
Input
The first line of the input contains one integer q (1≤q≤2⋅10^4) — the number of test cases.
The next q lines contain test cases. The i-th test case is given as the string s consisting of at least 1 and no more than 105 characters ‘L’, ‘R’, ‘U’ and ‘D’ — the initial sequence of instructions.
It is guaranteed that the sum of |s| (where |s| is the length of s) does not exceed 105 over all test cases (∑|s|≤105).
Output
For each test case print the answer on it. In the first line print the maximum number of remaining instructions. In the second line print the valid sequence of remaining instructions t the robot has to perform. The moves are performed from left to right in the order of the printed sequence. If there are several answers, you can print any. If the answer is 0, you are allowed to print an empty line (but you can don’t print it).
Sample Input
6
LRU
DURLDRUDRULRDURDDL
LRUDDLRUDRUL
LLLLRRRR
URDUR
LLL
Sample Output
2
LR
14
RUURDDDDLLLUUR
12
ULDDDRRRUULL
2
LR
2
UD
0
换而言之:
给出一段表方向的字符串,u、d、l、r分别表示向上、向下、向左、向右,让你重新排列,使其走出去再回到原点,除了原点能走两次以外其他点都只能走一次,输出走的次数和走法(不管先后)。
思路:
-
最简单的走法就是绕一圈,先全是上,再全是右,全是下,全是左,即上的次数=下的次数,左的次数=右的次数,求两组对应方向的较小值,两值之和的两倍即是走的次数。
-
或者有一个方向出现次数是0,则对应的反方向则也为0,另外两个方向就只能各一个
例如:上,出现次数是0,则只有一种情况,向左走,再向右走回原点(输出LR),结束。 -
又或者上下、左右都有出现0的情况,直接输出0,结束。
代码步骤:
- 定义q存储指令数。
- 定义string s保存指令
- 定义l、r、u、d分别保存左右上下的步数
- x取l、r中最小值,y取u、d中最小值
- x、y都非0属于第一种情况,输出(x+y)*2,转行分别依次输出x个L和R,y个U和D,当x和y有一个为0,属于第二种情况,x为空输出2和“UD”,y为空输出2和“LR”,都为0属于第三种,输出0
AC代码:
#include <bits/stdc++.h>
using namespace std;
int main()
{
int q;
string s;
cin >> q;
while(q--)
{
int l=0,r=0,u=0,d=0;
cin >> s;
int len=s.size();//size函数返回string类型s的字符长度
for(int i=0;i<len;i++)
{
if(s[i]=='L') l++;
else if(s[i]=='R') r++;
else if(s[i]=='U') u++;
else d++;
}
int x=min(l,r),y=min(u,d);//min获取最小值
if(x&&y)//当x和y都不为0,第一种情况
{
cout << ((x<<1) + (y<<1)) << endl;//<<1二进制左移1,相当于乘二
for(int i=0;i<x;i++) cout << 'L';
for(int i=0;i<y;i++) cout << 'U';
for(int i=0;i<x;i++) cout << 'R';
for(int i=0;i<y;i++) cout << 'D';
cout << endl;
}
else
{
if(x) cout << 2 << endl << "LR" << endl;//x不为0
else if(y) cout << 2 << endl << "UD" << endl;//y不为0
else cout << 0 << endl;//x和y都为0
}
}
return 0;
}