Piggy-Bank

Piggy-Bank

原题目描述:

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

简而言之,ACM有一个存钱罐,ACM可以往里面存钱,但是取钱必须打破存钱罐,每次买东西存钱罐都是满的,为了确定每次买东西存钱罐里面的钱都足够,所以要设计一个计算存钱罐满的时候可以储存的最低价值。

输入:
第一行,输入一个测试案例数T。
看接下来每个案例第一行输入E和F,分别为存钱罐空载和满载的重量,题目规定1 <= E <= F <= 10000,第二行输入硬币种类N(1 <= N <= 500),接下来N行,每行输入两个数,P和W,分别表示第N种硬币的价值和重量。

思路:
动态规划(又称dp背包)
假设

vec[i][j]为前i种硬币j重量的下存钱罐的最小价值。
ans为存钱罐可容纳硬币总重量。
w[i]为第i种硬币的重量
p[i]为第i种硬币的价值

核心代码为:

for(int i=0;i<n;i++)
{
	for(int j=w[i];j<=ans;j++)
	{
		vec[i][j]=min(vec[i][j],vec[i-1][j-w[i]]+v[i];
	}
}

空间优化后如下:

for(int i=0;i<n;i++){
			for(int j=w[i];j<=ans;j++){
				vec[j]=min(vec[j],vec[j-w[i]]+v[i]);
			}
		}

注意:
由于是取最小值,vec数组需要初始化为无穷大(INF=0x3f3f3f3f),但vec[0][0]或者vec[0]需要初始化为0,否则min将无意义。

AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
int v[10010];
int w[10010];
int vec[1001000];
int main(){
	int k;
	cin>>k;
	while(k--){
		memset(v,0,sizeof(v));
		memset(w,0,sizeof(w));
		int a;
		int b;
		int ans;
		cin>>a>>b;
		ans=b-a;
		int n;
		cin>>n;
		for(int i=0;i<n;i++){
			cin>>v[i]>>w[i];
		}
		memset(vec,INF,sizeof(vec));
		vec[0]=0;
		for(int i=0;i<n;i++){
			for(int j=w[i];j<=ans;j++){
				vec[j]=min(vec[j],vec[j-w[i]]+v[i]);
			}
		}
		if(vec[ans]!=INF){
			printf("The minimum amount of money in the piggy-bank is %d.\n",vec[ans]);
		}else{
			cout<<"This is impossible."<<endl;
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值