Maximum Subsequence Sum (25 分)

牛客

Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​ , N​2​​ , …, N​K​​ }. A continuous ubsequence is defined to be { N​i​​ , N​i+1​​ , …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with
the first and the last numbers of the maximum subsequence. The numbers
must be separated by one space, but there must be no extra space at
the end of a line. In case that the maximum subsequence is not unique,
output the one with the smallest indices i and j (as shown by the
sample case). If all the K numbers are negative, then its maximum sum
is defined to be 0, and you are supposed to output the first and the
last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

提供两种解决方案

一、在线处理,O(n)

#include<iostream>
using namespace std;
	int* MaxSubSum(int* ptr, int num)
	{
		int* res = (int*)malloc(sizeof(int) * 3);
		int begin = 0;
		int end = 0;
		int flag = 0;
		int thisSum = 0, MaxSum = 0;
		int i;
		for (i = 0; i < num; i++)
		{
			//begin = *(ptr + i);
			thisSum += *(ptr + i);/*累加求和*/
			flag++;
			if (thisSum > MaxSum)
			{
				begin = *(ptr + (i - flag) + 1);
				MaxSum = thisSum;
				end = *(ptr + i);
			}
			else if (thisSum < 0)/*如果为负数*/

			{
				thisSum = 0;/*则不可能使后面的部分和增大应该舍去*/
				flag = 0;
			}
		}


		*res = MaxSum;
		*(res + 1) = begin;
		*(res + 2) = end;
		return res;
		//return MaxSum;
	}


	int main()
	{
		int num;
		int flag = 0;
		int* ptr;
	
		cin >> num;
		ptr = (int*)malloc(sizeof(int) * num);
		if (!ptr)
		{
			exit(0);
		}
		else
		{
			for (int i = 0; i < num; i++)
			{
				cin >>*(ptr+i);
			
			}
			for (int i = 0; i < num; i++)
			{
				if (*(ptr + i) < 0)
				{
					flag++;
				}
			}
			if (flag == num)
			{
				cout << 0 << " " << *(ptr) << " " << *(ptr + num-1) << endl;
				return 0;
			}
			int *res= MaxSubSum(ptr, num);
		
			cout << *(res) << " "<<*(res+1)<<" "<<*(res+2) ;
		

		}
	
		return 0;

	}

二:暴力破解

#include<iostream>
using namespace std;

int* MaxSubSum(int* ptr, int num)
{
	int* res= (int*)malloc(sizeof(int) * 3);

	int begin = 0;
	int end = 0;
	int thisSum, MaxSum;
	MaxSum = 0;
	int flag = 0;
	for (int i = 0; i < num; i++)
	{

		thisSum = 0;
		flag = 0;
		
		for (int j = i; j < num; j++)
		{
			
			thisSum += *(ptr + j);

			flag++;
			if (thisSum > MaxSum)
			{
				begin = *(ptr+(j - flag)+1);
				MaxSum = thisSum;
				end = *(ptr + j);
			}

			/*for (int k = i; k <= j; k++)
			{
				thisSum += *(ptr + k);

			}
			if (thisSum > MaxSum)
			{
				MaxSum = thisSum;
			}*/
		}
	}
	//return MaxSum;
	*res = MaxSum;
	*(res+1) = begin;
	*(res+2) = end;
	return res;

}

	


	int main()
	{
		int num;
		int flag = 0;
		int* ptr;
	
		cin >> num;
		ptr = (int*)malloc(sizeof(int) * num);
		if (!ptr)
		{
			exit(0);
		}
		else
		{
			for (int i = 0; i < num; i++)
			{
				cin >>*(ptr+i);
			
			}
			for (int i = 0; i < num; i++)
			{
				if (*(ptr + i) < 0)
				{
					flag++;
				}
			}
			if (flag == num)
			{
				cout << 0 << " " << *(ptr) << " " << *(ptr + num-1) << endl;
				return 0;
			}
			int *res= MaxSubSum(ptr, num);
		
			cout << *(res) << " "<<*(res+1)<<" "<<*(res+2) ;
		

		}
	
		return 0;

	}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值