DHCP:(4)华为交换机上部署DHCP服务以及DHCP中继

DHCP应用 专栏收录该内容
11 篇文章 0 订阅

实现目标

1、二层交换机初始化,对应接口加入对应VLAN
2、三层与二层之间配置trunk
3、配置VLAN接口,作为PC的网关
4、配置DHCP方式(一种基于全局,另外一种基于接口)
5、验证

拓扑图介

dhcp

说明:里面有2个VLAN,一个VLAN 2一个VLAN3,用二层交换机连接,然后在连接三层交换机,三层交换机上面配置DHCP服务,一个用基于全局的方式,一个用基于接口的方式,来了解华为DHCP的配置。

1、二层交换机初始化,对应接口加入对应VLAN

创建对应VLAN
[sw-s2700]vlan batch 2 to 3

接入PC的2个接口划入对应的VLAN,一个用Access方式,另外一个用hybrid
[sw-s2700]int e0/0/1
[sw-s2700-Ethernet0/0/1]port link-type access
[sw-s2700-Ethernet0/0/1]port default vlan 2
[sw-s2700-Ethernet0/0/1]stp edged-port enable

[sw-s2700]int e0/0/2
[sw-s2700-Ethernet0/0/2]port hybrid pvid vlan 3
[sw-s2700-Ethernet0/0/2]port hybrid untagged vlan 3
[sw-s2700-Ethernet0/0/2]stp edged-port enable

说明:配置了STP边缘端口能够跳过STP的状态机,获取DHCP地址的时候不用延迟。

2、三层与二层之间配置trunk

[sw-s2700]int g0/0/2
[sw-s2700-GigabitEthernet0/0/2]port link-type trunk
[sw-s2700-GigabitEthernet0/0/2]port trunk allow-pass vlan 2 to 3
说明:允许VLAN 2与VLAN 3的流量通过,这个华为默认只允许VLAN 1,其余的不允许。

3、配置VLAN接口,作为PC的网关

配置VLAN
[sw-s5700]vlan batch 2 to 3

配置VLAN接口
[sw-s5700]int vlan 2
[sw-s5700-Vlanif2]ip address 20.1.1.1 24
[sw-s5700]int vlan 3
[sw-s5700-Vlanif3]ip address 30.1.1.1 24

4、配置DHCP方式(一种基于全局,另外一种基于接口)

开启DHCP服务
[sw-s5700]dhcp enable

基于全局的配置方式
[sw-s5700]ip pool vlan2
[sw-s5700-ip-pool-vlan2]network 20.1.1.0 mask 24
[sw-s5700-ip-pool-vlan2]gateway-list 20.1.1.1
[sw-s5700-ip-pool-vlan2]dns-list 114.114.114.114
[sw-s5700-ip-pool-vlan2]domain-name ccieh3c.taobao.com
[sw-s5700-ip-pool-vlan2]lease day 1
[sw-s5700-ip-pool-vlan2]excluded-ip-address 20.1.1.2 20.1.1.100
说明:这里配置了一个地址范围20.1.1.0/24,然后网关、DNS、Domain以及租期,用于在VLAN2的分配

[sw-s5700]int vlan 2
[sw-s5700-Vlanif2]dhcp select global
说明:最后要在全局调用

基于接口的形式配置
[sw-s5700]int vlan 3
[sw-s5700-Vlanif3]dhcp select interface
[sw-s5700-Vlanif3]dhcp server dns-list 114.114.114.114
[sw-s5700-Vlanif3]dhcp server domain-name ccieh3c.taobao.com
[sw-s5700-Vlanif3]dhcp server lease day 1
[sw-s5700-Vlanif3]dhcp server excluded-ip-address 30.1.1.2 30.1.1.100
说明:select interface是开启DHCP接口形式的配置,他可以以该接口的IP网段为范围分配给PC,然后以自己接口为网关,所以不需要配置gateway参数,然后配置了其他的,比如DNS、Domain,租期等,然后排除地址的话,可以只分配某一段的范围。

5、验证

dhcp

可以看到地址已经获取到了。

dhcp
dhcp

测试没问题。

DHCP 中继配置

华为交换机上面DHCP中继的配置也有2种,一种是全局定义,然后接口调用,一种是接口直接指定,两者没太大区别。
基于全局的配置方式
[sw-s5700]dhcp server group 1
[sw-s5700-dhcp-server-group-1]dhcp-server 192.168.1.1
[sw-s5700-dhcp-server-group-1]dhcp-server 192.168.1.2

[sw-s5700]interface vlan 2
[sw-s5700-Vlanif2]dhcp select relay
[sw-s5700-Vlanif2]dhcp relay server-select 1
说明:这里定义了一个DHCP组,然后告诉服务器在哪,这里可以定义19个服务器地址,可以用来做备份的。然后接口下启用中继,然后调用之前定义的组。

基于接口的方式

dhcp

直接在接口下定义即可。

至于DHCP中继工作跟DHCP如何识别的,可以参考第二篇里面有介绍。http://ccieh3c.com

如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路Blog(其他平台同名),版权归网络之路Blog所有,原创不易,侵权必究,觉得有帮助的,关注、转发、点赞支持下!~。

  • 0
    点赞
  • 0
    评论
  • 1
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

相关推荐
©️2020 CSDN 皮肤主题: 1024 设计师:白松林 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值