树的遍历(天梯赛L2)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
#include<bits/stdc++.h>
using namespace std;
int hou[35],in[35]; // 存后序遍历、中序遍历 
int n;

struct node{
	int data;
	node *l,*r;
}; 

node *creat(int *hou,int *in,int n)  // 构建二叉树 
{  // 三个变量分别为 后序遍历首地址,中序遍历首地址,以当前节点为根节点的树的总节点数 
	node *head;
	head=(struct node *)malloc(sizeof(struct node));
	int idx;
	int tmp=hou[n-1];
	head->data=hou[n-1];
	if(n==0)
		return NULL;
	for(int i=0;i<n;i++)
	{
		if(in[i]==tmp)
		{
			idx=i;
			break;
		}
	}
	head->l=creat(hou,in,idx);
	head->r=creat(hou+idx,in+idx+1,n-1-idx);
	return head;
	
}

void showTree(node *head)  // 层序遍历 
{
	queue<node *>q;
	node *p;
	q.push(head);
	int flag=1;
	while(q.size()!=0)
	{
		p=q.front();
		q.pop();
		if(flag==1)
		{
			cout<<p->data;
			flag=0;
		}
		else
		{
			cout<<" "<<p->data;
		}
		if(p->l)
			q.push(p->l);
		if(p->r)
			q.push(p->r);
	}
}

int main()
{
	cin>>n;
	for(int i=0;i<n;i++)
		cin>>hou[i];
	for(int i=0;i<n;i++)
		cin>>in[i];		
	node *T=creat(hou,in,n);
	showTree(T);
	return 0;	
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值