2021-06-07 算法笔记学习进行中......

4.1.1选择排序

每趟从待排序部分中选择最小的元素,令其与待排序部分第一个元素进行交换,形成新的有序区间。

void selectSort(){
	for (int i = 1; i <= n; i++) {    //进行n趟操作
		int k = 1;
		for (int j = i; j <= n; j++) {    //选出待排序序列中最小的元素,下标为k
			if (A[j] < A[k]) {
				k = j;
			}
		}
		int temp = A[i];     //交换A[k]与A[i]
		A[i] = A[k];
		A[k] = temp;
	}
}

4.1.2 插入排序

int A[maxn], n;    //n为元素个数,数组下标为1~n
void insertSort() {
	for (int i = 2; i <= n; i++) {      //进行n-1趟排序
		int temp = A[i], j = i;         //temp临时存放A[i],j从i开始往前枚举
		while (j > 1 && temp < a[j - 1]) {       //只要temp小于前一个元素A[j-1]
			A[j] == A[j - 1];               //把A[j-1]后移一位至A[j]
			j--;
		}
		A[j] = temp;      //插入

4.1.3 sort函数

cmp函数,比较函数

bool cmp(Student a, Student b) {       //这是一个二级排序的比较函数
	if (a.score != b.score) return a.score > b.score;
	else return strcmp(a.name, b.name) < 0;
}

PAT 1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

译文:

1025 PAT排名(25分)

编程能力测试(PAT)是由浙江大学计算机科学与技术学院组织的。每个测试应该在多个地方同时运行,测试结束后将立即合并排名。现在,您的工作是编写一个程序,以正确地合并所有的排名和生成最后的排名。

输入规格:

每个输入文件包含一个测试用例。对于每一种情况,第一行包含一个正数。N (≤100),测试地点的数目。然后N排名如下,每一行开头都包含一个正整数。K (≤300),测试的数量,然后K包含注册号码(13位数)和每个被试总分的行。一行中的所有数字都用空格隔开。

输出规格:

对于每个测试用例,首先在一行中打印被测试者的总数。然后以下列格式打印最终的名单:

registration_number final_rank location_number local_rank

地点编号从1到N。输出必须按最终等级的非递减顺序排序。分数相同的被试必须具有相同的等级,输出必须按其注册号的非递减顺序排序。

#include<stdio.h>
#include<string>
#include<algorithm>       //sort函数必加
using namespace std;     //sort函数必加
struct Student {
	char id[15];            //准考证号
	int score;              //成绩
	int location_number;    //考场号
	int local_rank;         //考场内排名
}stu[30010];
bool cmp(Student a, Student b) {           
	if (a.score != b.score) return a.score > b.score;     //先按分数从高到低排
	else return strcmp(a.id, b.id) < 0;            //分数相同按准考证从小到大排
}
int main() {
	int n, k, num = 0;      //num为总考生数
	scanf("%d", &n);        //n为考场数
	for (int i = 1; i <= n; i++) {
		scanf("%d", &k);     //该考场内人数
		for (int j = 0; j < k; j++) {
			scanf("%s %d", stu[num].id, &stu[num].score);
			stu[num].location_number = i;         //该考生的考场号为i
			num++;                //总考生数加一
		}
		sort(stu + num - k, stu + num, cmp);      //将该考场的考生排序
		//接下来添加考场内排名
		stu[num - k].local_rank = 1;
		for (int j = num - k + 1; j < num; j++) {
			if (stu[j].score == stu[j - 1].score) {
				stu[j].local_rank = stu[j - 1].local_rank;
			}
			else {
				stu[j].local_rank = j + 1 - (num - k);
			}
		}
	}
	printf("%d\n", num);
	sort(stu, stu + num, cmp);
	//接下来是所有考生排名
	int r = 1;
	for (int i = 0; i < num; i++) {
		if (i > 0 && stu[i].score != stu[i - 1].score) {
			r = i + 1;
		}
		printf("%s ", stu[i].id);
		printf("%d %d %d\n", r, stu[i].location_number, stu[i].local_rank);
	}
	return 0;
}

//代码是书上的,写的非常简洁精巧,虽然很容易看懂,但是非常巧妙,要多回顾。

//Orz我觉得我考试路上最大的拦路虎大概是英语。。。哭。。。

//多看看吧,熟能生巧,总有能轻松看懂的一天,加油(•̀ᴗ•́)و

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值