【深基6.例6】文字处理软件
题目描述
你需要开发一款文字处理软件。最开始时输入一个字符串作为初始文档。可以认为文档开头是第 0 0 0 个字符。需要支持以下操作:
1 str
:后接插入,在文档后面插入字符串 str \texttt{str} str,并输出文档的字符串;2 a b
:截取文档部分,只保留文档中从第 a a a 个字符起 b b b 个字符,并输出文档的字符串;3 a str
:插入片段,在文档中第 a a a 个字符前面插入字符串 str \texttt{str} str,并输出文档的字符串;4 str
:查找子串,查找字符串 str \texttt{str} str 在文档中最先的位置并输出;如果找不到输出 − 1 -1 −1。
为了简化问题,规定初始的文档和每次操作中的 str \texttt{str} str 都不含有空格或换行。最多会有 q q q 次操作。
输入格式
第一行输入一个正整数 q q q,表示操作次数。
第二行输入一个字符串 str \texttt{str} str,表示最开始的字符串。
第三行开始,往下 q q q 行,每行表示一个操作,操作如题目描述所示。
输出格式
一共输出 q q q 行。
对于每个操作 1 , 2 , 3 1,2,3 1,2,3,根据操作的要求输出一个字符串。
对于操作 4 4 4,根据操作的要求输出一个整数。
样例 #1
样例输入 #1
4
ILove
1 Luogu
2 5 5
3 3 guGugu
4 gu
样例输出 #1
ILoveLuogu
Luogu
LuoguGugugu
3
提示
数据保证, 1 ≤ q ≤ 100 1 \leq q\le 100 1≤q≤100,开始的字符串长度 ≤ 100 \leq 100 ≤100。
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
string str,tmp;
int n,m,t;
int main()
{
cin>>m>>str;
while(m--)
{
cin>>t;
if(t == 1)
{
cin>>tmp;
str = str+tmp;
cout<<str<<endl;
}
if(t == 2)
{
int x=0,y=0;
cin>>x>>y;
str = str.substr(x,y);
cout<<str<<endl;
}
if(t == 3)
{
int j = 0;
string r;
cin>>j>>r;
str.insert(j,r);
cout<<str<<endl;
}
if(t == 4)
{
string q;
cin>>q;
int i = str.find(q);
if(i!=-1)
cout<<i<<endl;
else
cout<<"-1"<<endl;
}
}
return 0;
}